Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Before everybody starts in on the "ASA7 is no longer supported"... Yes, yes, I get that.

I have a Dell Latitude D830 that I replaced the drive in. Put one of the new 256GB solid state drives in it. No lie when they say 24x faster then a normal drive. I installed Windows 7 Ultimate 32bit on it and have been working from there.

Anyway, I'm putting all my old software back on it. I've already put ASA6 on it and applied all of those maintenance upgrades. No problems. Then I installed ASA 7.0.2 off the CD. Again, no problems. However, when I go to install the 7.0.4 Maintenance upgrade, it starts up normally like it should. The progress bar works very quickly up to 99% complete with the message "Preparing the installshield setup process please wait."

I fire up the task manager and I can see the following running during this time...

___INS5576._MP InstallShield Engine 2,032K
_ISDel.exe 32-bit InstallShield Deleter. 1,656K

After about a minute, the preparing setup window closes and then nothing happens. I let it sit for about 30 minutes at one point and the install process never started up.

If I open the task manager back up, I can still see the two installshield components running. However, their memory footprint doesn't change, and the CPU usage stays at zero.

Anybody have any thoughts or suggestions on what might be happening here? I've already installed ASA7 on a Windows 7 Professional 64bit machine (with all the maintenance patches), and it installed without a problem.

As far as administrative settings, I have full administrative rights on both machines (initial and only user created on each machine), and I've even turned the UAC down to nothing so I don't get the nag screen.

Any suggestions would be appreciated!!

Jeff Gibson
Intercept Solutions - Sybase SQL Anywhere OEM Partner
Nashville, TN

asked 14 Mar '13, 17:38

Jeff%20Gibson's gravatar image

Jeff Gibson
accept rate: 20%

edited 15 Mar '13, 22:14

Mark%20Culp's gravatar image

Mark Culp

Small update on this. Allowed the update to just sit there. At about 32 minutes after I started it, it finally ran. The first time I had attempted to run this yesterday, it was over a USB drive, and it had gone for well over an hour without doing anything. This time I had physically copied the install file over to the machine first. Once the install started, the speed of the install itself seemed just fine.

As for ASA7, it seems to open just fine and everything is quite fast compared to the old drive that I have.

I'm moving on to ASA8. However, I am still curious as to why a standard installshield file like this would take so long to get to the point where it would finally start up.

One item that's curious to me is that the install off the CD ran just fine, yet the raw install on the hard drive is what caused the problem.

Anybody heard of any issues with Solid State drives causing issues with installs?

(14 Mar '13, 19:03) Jeff Gibson
Replies hidden

I have no idea why it would sit there for 30+ minutes and then run... but Windows is a strange beast. Did you try running any of the SysInternal tools (regmon, diskmon, filemon) to determine if the install was doing anything when it was "doing nothing"?

I wonder what would happen if you ran the maintenance install in a Win95 or Win98 compatibility mode?

(14 Mar '13, 21:28) Mark Culp

I had tried the XP compatibility mode, but hadn't gone any lower than that. If I run into the same issue with ASA8, then not only will I test that, but I'll also run some of the SysInternal tools to see what's going on.

I can tell you that watching the processes in the task manager. For the 30+ minutes I was waiting, the two Installshield items in the task manager never even budged. I expected to see a little CPU usage. Absolutely nothing. I will advise on further results.

(15 Mar '13, 00:07) Jeff Gibson

So much for that. ASA8 installed without one problem what so ever. Both the CD install 8.0.2, and the Maintenance updates as well as the EBF's.

(15 Mar '13, 04:04) Jeff Gibson

Jeff, this is a super long shot, but do you still have the installation CD for ASA 7?

I have an old application from the late 90's that a client still uses, and I'd like to move the installation to a virtual machine. My problem.. they lost the installer CD a LONG time ago.

I'd be happy to compensate you for your time to get an ISO or similar if possible.

Hope you see this, thanks!

permanent link

answered 04 Jan '22, 17:24

jermdine's gravatar image

accept rate: 0%

How can I reach you?

(10 Jan '22, 17:24) Jeff Gibson
Replies hidden

jermaine at

(10 Jan '22, 17:46) jermdine
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 14 Mar '13, 17:38

question was seen: 8,939 times

last updated: 10 Jan '22, 17:46