Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hello all, I upgraded our test database last night from asa 10 to asa The upgrade was pretty easy, however when I went to restart the db server, I was told could not find ..win32\dbsrv11.exe. In looking at the machine only the 64 bit version had been installed. I switched the startup command to ...bin32\dbsrv11.exe. All appears to be working fine, with one interesting exception.

There is a powerbuilder datawindow with a syntax error in it, that oddly enough ran fine in 10 but 11 does not like it. So a couple of questions here. 1. Are there any issues with running a db that had been 32 bit, but is now using the 64 bit engine? I did the migration on the same machine, did it automatically convert the db to 64 bit in the migration ? 2. The sql that is in question had two periods in a column name

select from bar crt.

The double period generates no errors in version 10 (went back and verified) however in the version 11 database it generates the error "owner 'crt' used in a qualified colun reference does not match correlation name". SQLCODE=-845. If I remove the second period in 11 it runs fine. Is this a function of moving from 10 to 11 or from 32 bit to 64 bit, both, neither ... ???


asked 30 Aug '11, 10:50

trexco's gravatar image

accept rate: 0%

edited 30 Aug '11, 11:48

Martin's gravatar image


The database file itself is not different between 32 and 64 bit database engines, it's just the database server software that is different.

Therefore the behaviour change you have noticed should not be dependent on the database server's bitness. You might take a look at the "Behaviour changes" sections in the docs - it might be documented there.

(30 Aug '11, 11:54) Volker Barth

The SQL Anywhere database files are totally independent of the 32/64 bitnes of the system, so the same file can be used to be run in a 32 bit database server or the 64 bit version of the database server.

I think, that the double point problem is really just a syntax problem, which you have to correct when using the 11.0.1 version of the product. It was probably not intended to access a column specific for user crt?

permanent link

answered 30 Aug '11, 12:01

Martin's gravatar image

accept rate: 14%

Agreed that the double period (..) is a syntax issue, I was just very suprised that it worked in version 10 and did not in version 11. I have already corrected the sql, and was trying to identify exactly why it worked in 10 and not in the 11 migrated database. This would help evaluate the success of the migration against our various applications before moving on to migrating production.

(30 Aug '11, 12:58) trexco
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 30 Aug '11, 10:50

question was seen: 6,451 times

last updated: 30 Aug '11, 12:58