Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hello, I connect to Mobilink server using Sybase Central.

I get the following message on my side (client): ---------- Starting synchronization Connecting Upload starting Finishing upload Disconnecting Done, with errors Sync failed: Synchronization server failed to commit the upload Results of this synchronization: Failed with error: -794 Download timestamp: 2011-09-15 09:47:02.328000 Upload failed No ignored rows No part download remaining Authentication value: 0 (0x0000)

Server log file gives me this message:

[10012] The consolidated and remote databases disagree on when the last synchronization took place, the progress offsets are 11 in the consolidated database and 3 in the remote database. The remote is being asked to send a new upload that starts at the last known synchronization point I. 2011-09-15 09:44:07. <82> Progress offsets for the publications that are explicitly involved in the current synchronization I. 2011-09-15 09:44:07. <82> Subscription id 2: consolidated progress 11 and remote progress 3 I. 2011-09-15 09:44:07. <82> Progress offsets for the publications that are not explicitly involved in the current synchronization I. 2011-09-15 09:44:07. <82> Subscription id 1: consolidated progress 0 and remote progress 0 I. 2011-09-15 09:44:07. <82> Synchronization complete

I dont see any update onto my DB.

Do you have any idea on what's going on?

Thanks in advance. S

asked 15 Sep '11, 04:00

devdevoteam's gravatar image

accept rate: 0%

retagged 19 Sep '11, 11:04

PhilippeBertrand%20_SAP_'s gravatar image


In situations like this, the type of remote is extremely useful. Are you using UltraLite, UltraLite J, or dbmlsync?

Is there a farm of MobiLink servers or just the one?

(15 Sep '11, 09:35) PhilippeBert...

When you say "connect to MobiLink using Sybase Central", how exactly did you do this? Were you using an UltraLite tool?

(16 Sep '11, 10:04) PhilippeBert...

the remote is Mobilink12. as client we use ultralite12 and an android application.

(16 Sep '11, 10:23) devdevoteam
Replies hidden

MobiLink is not a remote - it is the technology that synchronizes the remotes with a consolidated. Remote and client mean the same thing.

But you said in your original question that you used Sybase Central. I'm assuming you use the ul sync tool. Where did you get the client database from? Did you copy it from a device?

Is there just one MobiLink server or a farm?

(16 Sep '11, 10:51) PhilippeBert...

sorry I was wrong in calling Mobilink as remote. I use SybaseCentral and I downloaded it from internet. Is not a farm but just one server.

(16 Sep '11, 11:51) devdevoteam

I'm quite sure Philippe would like to know where you get the remote database from (i.e. whether you copied that from a device which might have already synced), not the SQL Anywhere software...

(16 Sep '11, 13:11) Volker Barth

Hello, it was not me in doing that but in order to generate remote database has been followed those steps: - through Sybase Central, Click on: Mobilink 12 > ServerName > Synchronization models - right key on db - click on "Deploy..." - choose "Deploy immediately using last deployment settings" - Finish.

Thank you in advance, S

(19 Sep '11, 08:54) devdevoteam

That helps...I asked our MobiLink plugin for SYbase Central person to look at your question.

(19 Sep '11, 11:06) PhilippeBert...

That doesn't tell us whether you are creating a new remote database when deploying your synchronization model, or deploying to an existing remote database. To see what the "last deployment settings" are, choose the "Run this wizard initialized with last deployment settings" and note whether you deploying to a new remote database or an existing remote database.

(19 Sep '11, 11:25) Graham Hurst

deploying is to a new remote database. Thanks, S

(19 Sep '11, 12:09) devdevoteam

A new remote database won't have a remote ID and (for UltraLite remotes) the progress offset will be zero. So if you are deploying to a new UltraLite remote, it should create a new UDB file that is "clean" for copying to different remotes.

  • Did you synchronize the new UDB file on the PC before copying to the Android device?

  • Is your application explicitly setting the remote ID?

(19 Sep '11, 12:55) Graham Hurst

yes, I did. That's because I try first if synchronization works with SybaseCentral and then with my application. I do not set any remote ID, I just set the following params: httpParms.setHost("xxx"); httpParms.setPort(xxx); syncParms.setUserName("xxx"); syncParms.setPassword("xxx"); syncParms.setPublications("xxx");

(19 Sep '11, 15:49) devdevoteam
Replies hidden

As Graham has stated, once you do sync, you will automatically set a remote ID. See his answer below to understand the effect and cause...

(19 Sep '11, 15:59) Volker Barth

Please is there a way to set UDB file progress offset and remote ID (i.e. by command line)?

(20 Sep '11, 08:17) devdevoteam
Replies hidden
Comment Text Removed

Using dbisql you may unset the ML remote ID with

SET OPTION ml_remote_id=;

I think this would suffice to solve the problem however if you want to clear the progress ID, you probably need to unload and reload the udb using ulunload and ulload.

(20 Sep '11, 08:29) PhilippeBert...

thank you for your response, Philippe. I tried it and I get such an error with errorcode=-1118. As you know this is its probable cause: The MobiLink server uses the remote id to track synchronization progress. If the status of the previous upload is unknown then you must resolve this condition before changing the remote id.

Is there a way to resolve the fact that "the status of the previous upload is unknown"? I dont see anything from your documentation.

Thank you in advance. S

(21 Sep '11, 04:35) devdevoteam

I haven't been able to track down how to reset the sync progress in the consolidated database for an UltraLite client. Hopefully @RussC_FromSybase or another MobiLink expert will pickup the problem.

If you are still in development mode, I would just trow out all client versions of the database and redeploy the model. Make sure you have unique remote ids.

(22 Sep '11, 11:24) PhilippeBert...

For v8 MobiLink clients, I remember to have fiddled around with the ml_subscription.progress column. As the "ML system tables" are still user-defined tables from the consolidated dbms, you can adjust the value as needed (as long as you know what you are doing).

Not sure if this still applies to v12 and UltraLite clients. You may also have a look at the newer system procedures like ml_reset_sync_state.

(22 Sep '11, 13:03) Volker Barth

An update on that table (ml_subscription) seems to work apparently but when you perform a selection on that data I actually see that the update did not take any effect. So my problem is still open.

(23 Sep '11, 05:38) devdevoteam

Shortly, I need to perform sync from my android application (containing a remote db) to this consolidate db. Any query on my remote db (from my app) works but I cannot synchronize my remote db to the consolidate db. the error I get is always the same -794 caused by the difference between the two progress offset. Please in order to make sync works, is there another thing I can do?

(23 Sep '11, 05:47) devdevoteam

Okay, I have a very similar problem, but let me lay it out fully as I have not read anything here that has solved my problem. We are writing a remote application, the remote client is Windows CE 5.0. Our DB is Oracle 11, we are running a single MobiLink server between the two and using Sybase Central to manage the process. We rolled out our first test device with the app and synced it a few times, worked great. Now we are ready to roll out our second device. We created a second user using mluser and assigned it to the second device. I pulled the original udb from the remote directory on the server (the file which we installed on the first device) and placed it on the second device. I expected that it would sync and update the udb to the current version of the main DB. Of course this did not happen. I got the [10012] error.

So now I have tried to update the udb file on the server using Sybase Central (Connect to UltraLite 12 | Right click on the file | Select Synchronize | set the user/pass and Finish), but this did not work either, in fact I got the exact same error.

So given all of this how do I roll out my second device? This seems like a totally logical sequence of events but it does not work. Have I missed something?

(19 Oct '11, 16:20) nbunney
(20 Oct '11, 13:10) nbunney
More comments hidden
showing 5 of 22 show all flat view

The error message tells that there's obviously a progress mismatch between your consolidated and remote databases. That means they're out of sync. This may happen when you use an older copy of the remote (e.g. a backup) to sync with the current consolidated, and the remote had successfully synced in the meantime.

(The opposite situation with a "old consolidated" can happen as well.)

That would often be a valid reason to re-build the remote. For SQL Anywhere clients, the DBMLSync -rb option may help to cure the symptom, as then the client's progress offset will be used to decide what to download. However, that may or may not lead to inconsistent data.

For Ultralite clients, the following doc part may explain more.

permanent link

answered 15 Sep '11, 07:49

Volker%20Barth's gravatar image

Volker Barth
accept rate: 34%

edited 15 Sep '11, 07:50


thank you for this. It worked but sometimes it doesnt work as I get this result:

Sync failed: MobiLink communication error -- code: 86, parameter: 404, system code: 0 Results of this synchronization: Failed with error: -1305 Stream error code: 86 System error code: 0 Download timestamp: 2011-09-16 11:47:19.343000 Upload failed No ignored rows No part download remaining Authentication value: 0 (0x0000)

doc does not give me much info about it. Any idea on what the problem might be?

(16 Sep '11, 05:58) devdevoteam

when instead I try to sync from my client android application I get the same error

09-16 13:33:17.856: WARN/System.err(419): com.ianywhere.ultralitejni12.implementation.JniException: UltraLiteJ Error[-1305]: MobiLink communication error -- code: 57, parameter: donotshowmyparam, system code: %3

Please, what does "code: 57" mean?

(16 Sep '11, 06:50) devdevoteam
Replies hidden

MobiLink errors and warnings are documented in the docs. You may just enter the error code in the docs's "Search box".

Here is the doc for error code 57.

(Note, warnings have code > 0, errors < 0).

Besides that, I can't comment on the source of these errors. But my impression is that the new errors you have reported have a different background than the error message from your question.

(16 Sep '11, 07:51) Volker Barth
Comment Text Removed

In addition to Caution that @Volker provided a link to (copied below), I would add the following:

You must not copy an UltraLite database that has been synchronized from on client to another, or share ML remote ids. If you wish to copy a database, you must reset the ML remote id. Each client must have a unique ML remote id to maintain independent state.


Because UltraLite increments the progress counter each time a synchronization occurs, you cannot synchronize an UltraLite database to different consolidated databases. If the progress counter value is not zero and does not match that sequence number stored in the consolidated database, MobiLink synchronization reports an offset mismatch and synchronization fails. You cannot replace an UltraLite database with a backup copy if the progress counter is older than the current value.

permanent link

answered 16 Sep '11, 11:06

PhilippeBertrand%20_SAP_'s gravatar image

accept rate: 22%

edited 28 Sep '11, 13:33

Here's what I think led to your original problem.

  1. You used a synchronization model to deploy to an UltraLite remote database (UDB file) on your PC, and synchronized that at least once from the PC.
    -> That changes the UDB file to have a remote ID and a non-zero progress offset.
  2. You then copied that UDB file to your Android device and synchronized several times.
    -> Each sync bumps up the progress offset in the Android copy of the UDB file, but not in the PC copy.
  3. You then redeployed to the PC copy of the UDB file.
    -> The PC copy will then have the same remote ID, but a much earlier progress offset, causing the error whether you sync it from the PC or copy it to the Android device and sync it.

You either needed to copy the UDB back from the Android device before redeploying to it, or not copy a synchronized UDB file to your Android device.

permanent link

answered 19 Sep '11, 11:42

Graham%20Hurst's gravatar image

Graham Hurst
accept rate: 29%

edited 19 Sep '11, 11:44

Comment Text Removed

If the ml_reset_sync_state procedure that @volker suggested does not work and/or you correctly identified subscription 2 for this particular remote and reset its progress to 2 or 3 and that did not work (did you commit?), then you need professional help.

While this forum is ideal for quick answers and getting community help, I think this issue may be just too complicated for here. I therefore suggest that you open a support case to help you resolve this quickly.

permanent link

answered 23 Sep '11, 16:13

PhilippeBertrand%20_SAP_'s gravatar image

accept rate: 22%

edited 28 Sep '11, 16:15

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 15 Sep '11, 04:00

question was seen: 8,257 times

last updated: 20 Oct '11, 13:10