Hello all,

I am facing an issue when trying to do a MobiLink sync via https from an UltraLite client on iOS. We are running 17.0.0.1211.

I am able to reach the server via the webbrowser, but of course get an error. When synchronizing from the mobile device, I get the following messages:

MobiLink: E. 2018-12-20 12:01:06. <main> [-10376] Received unexpected HTTP traffic on port 2441

Outbound Enabler:

I. 2018-12-20 12:36:26.015+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19} R{1} M{Spare count reduced to 11}
I. 2018-12-20 12:36:26.022+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} R{1} M{Sending 390 bytes to backend.}
I. 2018-12-20 12:36:26.027+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} R{1} M{Reading 61 byte opcode and data}
I. 2018-12-20 12:36:26.039+0100 T{0000126c} J{10.187.106.61#SAM_DEV#mobilink1#19#dn} R{1} M{Read 0 from backend}
I. 2018-12-20 12:36:26.045+0100 T{0000126c} J{10.187.106.61#SAM_DEV#mobilink1#19#dn} R{1} M{Sending 7 byte OE_BACKEND_DISCONNECTED}
I. 2018-12-20 12:36:26.051+0100 T{0000126c} J{10.187.106.61#SAM_DEV#mobilink1#19#dn} R{1} M{0000: 05 00 32 0B 00 00 00                             ..2....       
I. 2018-12-20 12:36:26.057+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} R{1} M{PacketRead packet-opcode: 0x31} I. 2018-12-20 12:36:26.062+0100 T{0000126c} J{10.187.106.61#SAM_DEV#mobilink1#19} R{1} M{OER DATA 0 11 0 18 | 390 0 | 0 OK ()} I. 2018-12-20 12:36:26.068+0100 T{0000126c} J{10.187.106.61#SAM_DEV#mobilink1#19} R{1} M{Reconnecting backend...} I. 2018-12-20 12:36:26.077+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{Received 61 byte RS_CLIENT_CONTINUE} I. 2018-12-20 12:36:26.083+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{0000: 31 11 00 64 00 03 1A 00 02 00 0C 00 00 00 02 00 1..d............ I. 2018-12-20 12:36:26.089+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{0010: 0C 00 00 00 48 89 92 63 10 50 67 B6 66 60 64 80 ....H..c.Pg.f`d. I. 2018-12-20 12:36:26.095+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{0020: 00 66 41 06 06 75 16 D6 D0 10 37 5D 0B 20 93 81 .fA..u....7]. .. I. 2018-12-20 12:36:26.110+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{0030: 8B 95 41 50 9D 99 87 01 00 00 00 FF FF ..AP.........
E. 2018-12-20 12:36:26.116+0100 T{00000ec0} J{10.187.106.61#SAM_DEV#mobilink1#19#up} M{OEE1036: A network connection was closed by the Relay Server or an intermediary while the Outbound Enabler was reading from it} D{h:\src\db\relayserver\c\oe_impl.c:2456}

Sync without the relay server works just fine.

On the client we use the following stream parameters:

host=DOMAIN;url_suffix=/rs17/client/rs.dll/SAM_DEV;port=443

Any idea how to fix this issue/how to troubleshoot it?

Thanks, Alex

asked 20 Dec '18, 06:45

Alexander%20Ilg's gravatar image

Alexander Ilg
236131629
accept rate: 50%

edited 20 Dec '18, 14:08

Reg%20Domaratzki's gravatar image

Reg Domaratzki
5.8k33786

The MobiLink error is not relevant to the problem you are encountering. That message is likely some outside (non sync based) request that hits that port i.e., a port sniffer. I think it would be interesting to see a verbose log for both RS and RSOE.

I would also suggest that you are running a very old version of 17. It appears to be the first SP for that release. I would at least review the bug fixes to see if any apply to your environment.

(20 Dec '18, 08:54) Chris Keating

Is it just a single RS and a single OE to a single ML Server?

Could you post the contents of the rs.config files on all the Relay Servers so we have a better idea of your configuration? Remember to remove the token information in the files if you are posting publicly.

Reg

(20 Dec '18, 14:11) Reg Domaratzki
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×318
×12

question asked: 20 Dec '18, 06:45

question was seen: 46 times

last updated: 20 Dec '18, 14:11