Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hello everyone,

I am experiencing the following problem that I would like kindly to ask you to help me with.

On a backend server I set up a consolidated SQL Anywhere database that is started with the Mobilink Server and runs fine. I also connceted afterwards successfully the Mobilink and SQL Anywhere Outbound enabler to a Relay Server. So the server side appears to be fine for me.

Now, on a Linux virtual machine client I am using the following script for my remote database:

/sqlanywhere12/bin32/dbmlsync -c "host=localhost;uid=DBA;pwd=sql" -o logMOB.txt -e "ctp=http;adr='host=myServer;port=1080;url_suffix=/cli/iarelayserver/Farm.MOB/'"

with myServer being reachable and Farm specifing the server farm. Now when I send this command I receive the following error: E. 2011-11-10 12:20:37. An error status was returned: '400'.

On the server side the Mobilink outbound enabler reports: E. 2011-11-10 03:20:41. <backend-0000> Session was disconnected at the middle of a packet sequence. Aborting sidx=65535

and the Mobilink server reports: E. 2011-11-10 03:20:41. <main> [-10376] Received unexpected HTTP traffic on port 2439

I would appreciate very much any help you could give me on this matter.

Thank you very much.

Best regards Sebastian

asked 10 Nov '11, 06:30

SFeg's gravatar image

accept rate: 0%

retagged 10 Nov '11, 07:51

Daz%20Liquid's gravatar image

Daz Liquid

Please include version of SQL Anywhere you are using, OS platform hosting backend server, OS platform hosting Relay Server, all command lines used for starting all the components (e.g. rsoe, MobiLink, relevant portions of Relay Server config file).

(10 Nov '11, 09:48) Bill Frier

My guess would be that MobiLink is listening for TCPIP on port 2439 while the client is talking HTTP. If this is the case the MobiLink -x option would be used to setup the intended sync stream. e.g. -x http(port=2439). If you go to another port for HTTP such as 80, then you would need to update the rsoe command line accordingly.

permanent link

answered 10 Nov '11, 10:40

Bill%20Frier's gravatar image

Bill Frier
accept rate: 41%

Thank you very much for your help!

In fact now it works just fine :) In the end it was exactly that MobiLink server expected TCPIP communication and not HTTP.

I would just like to ask you one final questions. When starting the dbmlsync with the command as indicated above dbmlsync -c "host=localhost;uid=DBA;pwd=sql" -o logMOB.txt -e "ctp=http;adr='myServer;port=1080;url_suffix=/cli/iarelayserver/Farm.MOB/'"

then after the synchronization is completed the client terminates. Instead I'd like it to continue to run and synchronize all the time. In the dbmlsync specification I did not find any option for that. I just found the -qc option that would shut the client down after synchronisation. Maybe you could give me a hint on that?

Thanks a lot!

(11 Nov '11, 06:52) SFeg
Replies hidden

This is in indeed a separate question. Please mark the original question as answered. For this new question, I would suggest you take a look at the the Dbmlsync API and SQL SYNCHRONIZE statements in combination with the -sm switch for dbmlsync. If this isn't sufficient to get you started, please post a new question. Thanks, Bill.

(11 Nov '11, 08:14) Bill Frier

One additional note, it is best to add follow-up information via the add new comment, rather than posting an answer.

(11 Nov '11, 08:16) Bill Frier

Thank you very much. I will keep this in mind. Have a good weekend

(11 Nov '11, 08:42) SFeg

...I have felt free to "clean up" (aka "comment reorganisation") and hope you don't mind:)

(11 Nov '11, 08:43) Volker Barth

FYI, I converted the answer to a comment under Reg's answer.

(11 Nov '11, 11:40) Graham Hurst
showing 1 of 6 show all flat view

Your URL suffix looks different than I was expecting. I would have expected the URL suffix to look more like :


If you change the URL, does that help? What does your start line for the RSOE look like? I'm not convinced the server side is setup correctly either.


permanent link

answered 10 Nov '11, 09:01

Reg%20Domaratzki's gravatar image

Reg Domaratzki
accept rate: 37%

Hi Reg,

thank you very much for your help!

If I change the suffix accordingly the client outputs: E. 2011-11-10 15:48:51. An error status was returned: '404'. The backend server log reports: E. 2011-11-10 06:04:31. <13147.2597275920.-> RSE1001: Client specified an unrecognized farm name 'client' in the URL

The RSOE is started like that: rsoe.exe -cr "host=relayServer;port=80;url_suffix=/srv/iarelayserver/" -cs "host=localhost;port=2439" -f Farm.MOB -id CurrentServer.MOB -o rsoe.log

Thank youa lot. Best, Sebastian

(10 Nov '11, 09:51) SFeg
Replies hidden

The rs_client.dll is part of the suffix for IIS, but not Apache. More details are recorded in the http.conf file, so the Apache URL_SUFFIX is simpler.

(10 Nov '11, 09:56) Bill Frier

Bill had pointed out the differences between extensions when using IIS versus Apache, which explained my confusion.

Given that the URL is fine, can you please provide the following output files when you attempt a synchronization :

1) The dbmlsync log 2) The log file generated by rshost on Apache 3) The RSOE log 4) The MobiLink Log

If you could run dbmlsync and MobiLink with "-v+", run the RSOE with "-v 5" and change the rs.config file to use verbosity=5 for the Farm.MOB farm and the CurrentServer.MOB backend, that would provide us with the best chance of figuring out what is going on.


(10 Nov '11, 10:21) Reg Domaratzki
Comment Text Removed

Thanks Bill. I guess everyone now knows I've never configured the Relay Server on Apache. :)

(10 Nov '11, 10:35) Reg Domaratzki
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 10 Nov '11, 06:30

question was seen: 10,448 times

last updated: 11 Nov '11, 11:40