Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hi I try to upgrade from 6.0 to 12.0. During the upgrade, the following error occurs.

Compared with normal DATABASE, I made ​​sure that the users & groups - dbo is in uppercase. Probably think this is the cause, I wonder if there is a way to fix this.

Resolved in version 6.0, if the DB rebuild, which takes too much time. Is there any other workaround?


SQL Anywhere Unload Utility Version
Connecting and initializing
Unloading user and group definitions
Unloading table definitions
Unloading index definitions
Unloading functions
Unloading view definitions
Unloading procedures
Unloading triggers
Unloading SQL Remote definitions
Unloading MobiLink definitions
***** SQL error: User 'PUBLIC' already has membership in group 'dbo'

asked 11 Sep '12, 02:32

larry's gravatar image

accept rate: 0%

edited 11 Sep '12, 09:17

Breck%20Carter's gravatar image

Breck Carter

I have experienced wierd messages during in-place upgrades. They were always caused by previous errors I had made which seemed to be functioning just fine in the old db (such as creating an index without an object name: worked fine in ASA 10 but not in 11).

I discovered the "real" problem by creating an script file with dbunload and then searching for the offending term (public or dbo in your case). Once I discovered the underlying error, I 1) fixed it in the original db and repeated the in-place upgrade, or 2) edited the unload script file and then executed it manually.

permanent link

answered 11 Sep '12, 17:56

Bill%20Aumen's gravatar image

Bill Aumen
accept rate: 16%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 11 Sep '12, 02:32

question was seen: 2,304 times

last updated: 11 Sep '12, 17:56