Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.

I upgraded my v 9.0.2 database to version 11.0.1 using dbunload -ar switch. This worked fine. I tried to run the script READ 'c:Program FilesSQL Anywhere 11MobiLinkupgrade9.0.2upgrade_asa.sql'; and received many errors. It looks like some tables are missing but mlserver seems to be running fine. Here is some of the code that failed.

drop procedure ml_qa_stage_status_from_client go

drop procedure ml_qa_staged_status_for_client go

drop procedure ml_qa_handle_error go

drop function ml_qa_get_agent_property go

drop function ml_qa_get_agent_object_property go

drop function ml_qa_get_agent_network_property go

drop function ml_qa_get_message_property go

drop view ml_qa_messages go

drop table ml_qa_notifications go

drop table ml_qa_status_history go

and this code had the wrong number of inserts error.

insert into #ml_qa_delivery (msgid,address,client,status,statustime,syncstatus) select md.msgid,md.address,md.client,md.status,md.statustime, md.syncstatus from ml_qa_delivery md go


asked 09 Mar '12, 10:08

jimboidaho's gravatar image

accept rate: 0%

What user ID did you use to run the MobiLink server upgrade script? Could you please follow the upgrade procedure described in the SA manual:

SQL Anywhere 12 - Changes and Upgrading » Upgrading to SQL Anywhere 12 » Upgrading MobiLink » Upgrading your consolidated database


(09 Mar '12, 10:37) Yufei Guo

I'd be interested in trying to figure out why the upgrade failed for these objets though if you're willing to help out. I don't suppose you have a backup copy of the v902 consolidate database on whch you can re-run the

(09 Mar '12, 10:38) Reg Domaratzki
Replies hidden

I have a copy but it is big 1.2 gig. I guess I could zip it up and ftp it to you.

I did follow the directions including logging in as dbo.

(09 Mar '12, 10:42) jimboidaho

I did not try the upgrade steps described in the doc. However, I did not see any error, when I ran the upgrade script file with the DBA use ID. Could you please tell us what exact steps and commands you used to run the upgrade script file?

(09 Mar '12, 11:22) Yufei Guo

I upgraded the database using dbunload -ar.
GRANT CONNECT TO dbo IDENTIFIED BY password; logged into isqlc as dbo SETUSER "dbo"; READ 'c:Program FilesSQL Anywhere 11MobiLinkupgrade9.0.2upgrade_asa.sql'; GRANT CONNECT TO dbo

(09 Mar '12, 11:28) jimboidaho

Reg, I have permission from my customer to send you the database I was using if you are still interested in seeing it.

(12 Mar '12, 14:54) jimboidaho

I am not sure why my reply was hidden so I will post here.

Reg, I have permission from my customer to send you the database if you are still interested.

(12 Mar '12, 14:56) jimboidaho

Yes, I'm still interested. E-mail me diretly and we'll sort out how you can send me the database. My direct e-mail is :, where you replace "firstname" and "lastname" with my actual first and last name.

(13 Mar '12, 10:35) Reg Domaratzki
More comments hidden
showing 5 of 8 show all flat view

These look like problems when upgrading the schema to support QAnywhere. If you're not using QAnywhere, these errors won't prevent other aspects of the ML Server from working.

permanent link

answered 09 Mar '12, 10:39

Reg%20Domaratzki's gravatar image

Reg Domaratzki
accept rate: 36%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 09 Mar '12, 10:08

question was seen: 1,538 times

last updated: 13 Mar '12, 10:35