Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

No match of row number between table > "<table_name>" and index "<pk_name>"

i rebuilded the index and updated the statistics but same problem when i validate the table with express check , same message.

Someone any idea? Drop it and create new?



asked 08 Aug '17, 05:29

pmiller's gravatar image

accept rate: 37%

edited 08 Aug '17, 05:30

Is the database used by other connections during the validation? Hint: Validation should be done on a "quiet" database, see here...

(08 Aug '17, 06:36) Volker Barth
Replies hidden
Comment Text Removed

Hi Volker, the daily validation is done on a backup without any user connections. For the last check i used the following statement on real database ( in iSQL)

validate table [Table] with express check;

first time there was an error on an FK, the i rebuild it and validate the table again with validate statement, express check in iSQL. There was no error concerning the FK, but a new one. Now at the PK, rebuild and update statistics show no positive effect. same error. So i will wait for validation tonight, when no user is connected.

(08 Aug '17, 09:46) pmiller

What version and build are you running? ...perhaps an EBF might help.

First, stop everything and check the RAM. Do that before any transient RAM errors get made permanent when the resulting corrupt data is written to disk. RAM errors can manifest themselves as ANY kind of data-related symptom.

Second, check the disk(s).

Then, try creating a second table and associated keys and indexes. Copy the data. Drop the original table. Use ALTER to rename the copy table. Try this on the backup copy to see if it makes dbvalid work.

(08 Aug '17, 10:18) Breck Carter
Comment Text Removed

Hi Breck, everytime when dbvalid shows an error and i load the backup into a networkserver (dbsrv) the database need a auto-log-recovery. When recovery is completed, i repair corrupted index, check the complete database with dbvalid.

Next Backup is valid, no errors, no autorecovery.

is it possible thats the same problem you described with RAM oder corrupted disk

(15 Aug '17, 03:50) pmiller

Glad you fixed it, but there should not be a need to repair indices "everytime when dbvalid shows an error", i.e. dbvalid should not report an error unless something really unexpected has happened...

Does sound like a somewhat corrupt system IMHO.

(15 Aug '17, 04:15) Volker Barth

Solution for me: Recreating indices works fine (GUI in Sybase Central) Then: dbvalid and express check (on a DB-Backup, nobody connected)

Thanks to Volker

If this not work unload the corrupted table, backup DB, rename corrupted table and load it as original

thanks to Breck

permanent link

answered 15 Aug '17, 03:34

pmiller's gravatar image

accept rate: 37%

edited 15 Aug '17, 03:35

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 08 Aug '17, 05:29

question was seen: 2,148 times

last updated: 15 Aug '17, 04:15