Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

I have a VS 2017 Dot Net app utilizing UltraLite.Net that syncs with my consolidated Oracle database via MobiLink 17. I have another VS 2017 UWP app that will not sync to the same consolidated database using the exact same Sync Parameters. It cannot find the “Host Name”. I have set the following Capabilities in the UWP app: Private Networks, Internet (Client & Server, and Enterprise Authentication, each one separately and then all three at once and keep getting the same error: Can’t find the Host Name. Any assistance in any direction would be appreciated. Thanks

asked 19 Jun '17, 07:22

BESpring's gravatar image

accept rate: 20%

The MobiLink Error is #57. Get this error using the server's name or IP Address.

(19 Jun '17, 09:53) BESpring

The problem is must be with UltraLite/MobiLink. I can access the DB server and others from my UWP app when I enable the "Private Networks" Capability with Windows.Web.Http and Windows.Networking.Sockets. This is the same error if I use a bogus server name with UltraLite.NET Ver.17. So is UltraLite broken or is it querying the network DSN differently then UltraLite.NET such I/we need to do something here?

(20 Jun '17, 07:10) BESpring

This should work of course :-)

Can you show how you are setting the sync parameters?

(20 Jun '17, 11:33) Tim McClements

Publications=PICS.AUTHORIZATION.2.0;SendColumnNames=false;SendDownloadACK=true; stream=http(host=SERVERNAME,port=8060,buffer_size=16000,timeout=240,persistent=on,version=1.1); MobiLinkUid=PIC;ScriptVersion=PICS.AUTHORIZATION.2.0

The above is the same parameter string as with UltraLite.NET that works.

GetLastError's error text return - "57,SERVERNAME,port=8060,buffer_size=16000,timeout=240,persistent=on,0"

(20 Jun '17, 13:02) BESpring

You should be using semicolons not commas to separate the parameters.

(20 Jun '17, 13:32) Chris Keating

Now I see the diff. between .NET and WinRt's Parameter strings. I was focused on the content. I could have sworn I read somewhere that the stream's parameters were comma separated and not semicolon separated. I took special care to do just that. Boy do I feel sheepish. It is connecting to the server now. Thnaks

(20 Jun '17, 14:26) BESpring
More comments hidden
showing 5 of 6 show all flat view
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 19 Jun '17, 07:22

question was seen: 1,632 times

last updated: 20 Jun '17, 14:26