Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.

Old People will recognize that version and build as one of The Greats, still functioning in many parts of the world. Young People, of course, will remain clueless :)

At some recent point, possibly after a Microsoft update to Windows 7, isql.exe stopped working when it comes time to open the GUI editor window on a database that it has (most probably) connected to (if it can't connect, it does display the GUI messages to that effect; see later).

WAGs are welcome, even ones that repeat what I've already tried and described below :)

The symptom is this: isql.exe just sits there in the DOS box...

alt text

The engine dbsrv50.exe starts OK on the local machine or another computer, and the client dbclient.exe starts OK on the local Win 7 machine.

alt text

If I don't have dbclient.exe running, isql.exe displays the following dialog boxes which indicates that it is PARTLY working (and an isql.exe entry exists in Task Manager)...

alt text

alt text

The symptoms are the same when the engine is running locally or on another computer; it can (probably) connect but not display the editor GUI.

Nothing shows up in the Event Viewer.

Turning off the firewall doesn't help.

Everything works OK when everything is run on Windows XP... and it USED TO WORK OK on Windows 7.

Using Run As Administrator does not help.

The yellow UAC warning dialog box does appear every time isql.exe is launched, regardless of whether or not Run As Administrator was used.

Turning off UAC does suppress the warning, but doesn't fix the problem.

Futzing around with isql.exe properties did not help; e.g., Take Ownership, Troubleshoot Compatibility, Run this program in compatibility mode for: Windows 95, stuff like that.

I can move all my V5 work to the XP computer so this isn't a showstopper, but any WAG that lets me work on one desktop would be most welcome!

Batch file to start server on XP computer...

SET SQLANY=C:\Program Files\Sybase\SQL Anywhere 5.0

"%SQLANY%\win32\dbsrv50.exe" -n ddd5 -o dbsrv50_ddd5_log.txt -x tcpip ddd5.db

Batch file to start dbclient on Win 7 computer...

"%SQLANY%\win32\dbclient.exe" ddd5 -x tcpip

Batch file to start isql on Win 7 computer...

"%SQLANY%\win32\isql.exe" -c "dbn=ddd5;eng=ddd5;uid=dba;pwd=sql"

asked 17 Aug '14, 08:58

Breck%20Carter's gravatar image

Breck Carter
accept rate: 20%

edited 17 Aug '14, 09:02

Using Run As Administrator to launch dbclient.exe on the local Win 7 machine to connect to dbsrv50.exe running on a network Win XP machine does make it possible to use the GUI editor of isql.exe on the local Win 7 machine to query the database on the network. that's a clue.

However, using isql.exe on a local dbeng50.exe database still remains out of reach. Funny that the hard thing (network connection) works but not the "easy" one (local connection).

ODBC complicates this whole affair, and has not been discussed here. It seems to want to launch its own copy of dbclient.exe rather than use one that's been pre-launched, which puts it in conflict with isql.exe... i.e., can't run Foxhound and isql.exe at the same time.

(17 Aug '14, 10:33) Breck Carter
Replies hidden

For me, works on Win7/64 with all patches installed. However, my build is slightly newer, and I have UAC turned off. Can it make a difference?

(18 Aug '14, 02:38) Dmitri

may be you first try Dmitri suggestion of updating to a new build of sa, and maybe running w7x64 along with it.

failing that, as last resort run xp mode or some virtualization partition for your isql 5 assuming you do have sufficient memory in your PC

(18 Aug '14, 03:04) gg99

If you think, Breck, that the issue is related to the latest updates, why cannot you remove them for last 1-2 months using Windows Recovery? I assume that you can check which DLLs are used by isql.exe (I use one of plugins of TotalCmd), you can try to get them from an old Windows release (e.g. install Windows on a VM) and put them to the application folder.

(18 Aug '14, 05:44) Vlad

Have you tried running dbeng50.exe / (local) dbsrv50.exe as administrator as well?

PS I was tempted to add the tag "archaeology" but that's just because I didn't bother to install anything older than v8 when I finally moved to Windows 8 and I've kept an old XP install for this kind of thing.

(18 Aug '14, 09:19) Justin Willey
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 17 Aug '14, 08:58

question was seen: 5,552 times

last updated: 18 Aug '14, 09:19