Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hi, I'm hoping some one has encountered this before. We are running Sybase 12 (installed in c:asa12) we have both 64 and 32 bit versions installed. When opening the server explorer tab in visual studio we get an error stating that the Sybase package failed to load, it then suggests checkingbthe activity log.XML file for VS which gives us the guid of the package and not much else.

Until now this has not been much of an issue as we just avoided usingbthat dialogue, however now we need to do some work with EF and could really do with getting in this working.

Please note when I say we, there are 4 of us with the same issue... So its not just something that I have screwed up!

Hoping that some one may have some ideas as to what could cause this, or some way that we can shed some more light on what the issue is?

Thanks in advance.

asked 08 Mar '14, 20:30

davidbarrett's gravatar image

accept rate: 0%


When opening the server explorer tab in visual studio we get an error stating that the Sybase package failed to load

Can you be more specific about the error/exception message displayed when you get to this point? Did Visual Studio offer a stack trace of the problem with the loading of the assembly? If so, was the error message one of:

  • System.TypeInitializationException: "The type initializer for 'iAnywhere.Data.SQLAnywhere.SAConnection' threw an exception."

  • System.ArgumentException: "Unable to find the requested .NET framework data provider. It may not be installed."

  • System.ArgumentException: "Failed to find or load the registered .Net Framework Data Provider"

  • iAnywhere.Data.SQLAnywhere.SAException: Cannot find the language resource file (dblgen12.dll)


Have you tried re-running the SQL Anywhere .NET Installation Utility (i.e. %SQLANY12%\\Assembly\\V4\SetupVSPackage.exe /install) to see if this resolves the issue?

(10 Mar '14, 11:46) Jeff Albion

Hi, Thanks for the reply.

There is no stack trace literally the only feedback I get is the image here : (Sorry not enough reputation points to upload direct to this forum)

Having a dig further into the actvitylog.xml the error in there is "CreateInstance failed for package [SQL Anywhere explorer]" - "80070057 - E_INVALIDARG"

I have tried rerunning the .net installation utility, Reinstalling sybase and most recently reinstalling windows, visual studio and sybase (The screen shot provided is from this fresh install of everything)

If you have any ideas what could be causing this Id be grateful, because I'm out of ideas now (the fresh install was my last hope!)

(11 Mar '14, 10:55) davidbarrett

Hi David,

CreateInstance failed for package [SQL Anywhere explorer]

Ahhh, that's somewhat more clear. Although, this is a component from SQL Anywhere 11 not 12 (as the SQL Anywhere Explorer was removed in 12.0.0). Did you also have SQL Anywhere 11 installed previously (or was it installed as a component as part of your fresh install)?

The SQL Anywhere Explorer was actually a component that was slowly deprecated throughout the course of 11.0.1. It was only briefly supported in Visual Studio 2010, and then 2010 support was dropped as of and higher (see: CR #576252). Visual Studio 2005 and 2008 support was also eventually dropped as of (see: CR #637453). The component was never considered for Visual Studio 2012 though, so I'm not 100% why you're seeing it even loaded here... particularly if this is a clean install. Are you loading previous Visual Studio settings when you're migrating...?

I believe you should just be able to disable/remove the SQL Anywhere Explorer extension by going to "Tools" → "Extensions and Updates...", click on the extension "SQL Anywhere Explorer" and click "Disable" or "Uninstall".

permanent link

answered 11 Mar '14, 16:13

Jeff%20Albion's gravatar image

Jeff Albion
accept rate: 25%


Neither my laptop or the virtual machine that I set up for this test have ever had v11 installed, the VM that was set up was literally done by pressing next on every step of the VS and Sybase installers without changing anything and no previous settings were imported into VS after the install, so what I am seeing seems to be the default behaviour out of the box.

Details of the MSI that I have installed here : and as you can see here it does not show in the tools - extensions & updates :

Anyway, if this is correct and it should not be available in 12 thats fine, do you know if it has been replaced with anything? We would like to use EF to provide the DAL for our application and would like to use some of the built in tools in VS which all share this dialogue so dont work!

If you have any insights into this it would be greatly appreciated!

Thanks David

permanent link

answered 12 Mar '14, 16:05

davidbarrett's gravatar image

accept rate: 0%

One other update, this is the details for the DLL in the Assemblies directory in the SQL Anywhere 12 folder:

So it all looks like its v12, further to that when I run the set up it explicitly states that its installed for VS 2010 & 2012:

Console Output:

C:Program Files (x86)SQL Anywhere 12Assemblyv4>SetupVSPackage.exe -i iAnywhere Solutions (R) SQL Anywhere Package for Visual Studio .NET Setup Utility Version Copyright (C) iAnywhere Solutions 2008. All rights reserved Installing SQL Anywhere Package for Visual Studio 2010...... Succeeded Installing SQL Anywhere Package for Visual Studio 2012...... Succeeded C:Program Files (x86)SQL Anywhere 12Assemblyv4>

Of course I have to now uninstall it again if I want to use VS Server explorer to connect to any other databases... :)

permanent link

answered 12 Mar '14, 16:22

davidbarrett's gravatar image

accept rate: 0%

albeit quite a late but one could try microsoft odbc instead in server explorer using user of system dataset. I know it worked for for me with vs2017, 2013

(02 May '19, 00:30) gg99
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 08 Mar '14, 20:30

question was seen: 5,644 times

last updated: 02 May '19, 00:30