Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in August and this forum will be retired.

I have a Sun X2250 Running SUSE Linux Enterprise Server 10. It's getting stuck during the boot process when trying to start the SyBase DB. Any suggestions on how to force the server to load past this? Any way to get it to skip this step when booting? I have tried booting into single user mode and turning off the Sybase on startup. When I did this it complained, rebooted, and tried to start Sybase again. alt text

asked 13 May '13, 10:04

mav1c's gravatar image

accept rate: 0%

edited 13 May '13, 10:58

Mark%20Culp's gravatar image

Mark Culp


Up voted for the genius way of taking a "screenshot" :-) love it.

(16 May '13, 06:47) Daz Liquid

I suspect that the database server is recovering your database and hence the appearance that it has hung.... but this is just a guess.

Exactly what are you referring to as "it" in your statement "When I did this it complained". I.e. What is complaining and what was the message?

What version and build of SQL Anywhere are you using?

Without knowing more it is difficult to make any recommendations.

permanent link

answered 13 May '13, 10:55

Mark%20Culp's gravatar image

Mark Culp
accept rate: 41%

edited 13 May '13, 10:59

By "it" I mean the server/linux. Basically it sees that Sybase isn't set to start, and says it has to fix the services. Reboots, turns sybase back on, and then sits at this point again.

It may be trying to repair the DB, but it's not successful. I left the server in this state Sunday afternoon, and when I came in this morning it was still in the same state.

Since I can login in Single user mode, are there any commands I can run to try and repair the DB?


(13 May '13, 10:59) mav1c
Replies hidden

Does your server have a console log? If yes then you should look at the log to determine if there are any messages that might help determine what is happening during startup. If there isn't a console log then add one - add "-o <some-file-name>" to the service definition.

If you want to test the state of the database in single user mode then just try running "dbsrvX databasename.db" from the command line (you may need to source the {sa|asa} file first? - it will depend on your environment).

Please tell us what version and build number of SQL Anywhere that you are using?

(13 May '13, 11:04) Mark Culp

I was able to resolve the issue. Once in single user mode I was able to go to the /home/sybase/databases directory and see there was an "original" version of the DB and Log there. I renamed the existing DB and Log, and copied the originals in their place. Rebooted and the server started up fine. The DB was re-populated by running a command on the server that feeds data to this server, and all is well again.

permanent link

answered 15 May '13, 12:30

mav1c's gravatar image

accept rate: 0%

edited 15 May '13, 12:31

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 13 May '13, 10:04

question was seen: 6,944 times

last updated: 16 May '13, 06:47