Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

I've got a maintenance plan running that does a validation and then a backup using

backup database directory 'P:\\GKBackups' wait before start transaction log rename;

There seems to be something wrong with the database or something, because the backup file is 'not a valid database file', and it seems the event for the maintenance plan never finished (connections were still disabled; never got email).

Any thoughts?


UPDATE: I did some logging, but I got NOTHING. The backup just never finishes. It never throws an exception either. I have absolutely nothing to go on. The strange thing is, though, that dbbackup.exe will work, just the backup database command will not.

asked 09 Nov '10, 13:06

Calvin%20Allen's gravatar image

Calvin Allen
accept rate: 25%

edited 10 Nov '10, 13:59


Any more infos (dbsrv19 -o log output, error code)?

(09 Nov '10, 14:20) Volker Barth

@Volker - That's all I have for now, I'll get the rest for you.

(09 Nov '10, 15:02) Calvin Allen

Look: Well, as you see, I'm already on SQL Anywhere 19 (dbsrv19) - so I can't tell whether I'll be of help:)

(09 Nov '10, 15:36) Volker Barth

@Volker - Yeah, I caught that, but I wasn't going to say anything ;)

(10 Nov '10, 00:17) Calvin Allen

Without more infos it's really hard to tell (and I ain't that expert for backups either). A few more questions: Has the MT plan ever worked, or is it just newly created? Does DBBACKUP -s work (it does a server-side backup, just like the BACKUP STATEMENT)? Does a simple log backup work?

(11 Nov '10, 08:23) Volker Barth

Any update on this one Calvin?

(08 Sep '11, 20:02) Siger Matt
More comments hidden
showing 5 of 6 show all flat view

If the backup didn't finish, then the file will be invalid. The last thing we do after the backup completes is update the header of the file to mark it as valid. What you need to find out is why the backup never finished.

permanent link

answered 09 Nov '10, 16:35

John%20Smirnios's gravatar image

John Smirnios
accept rate: 37%

Are there any internal issues that would cause a backup not to finish? I had already did a full validation on the database, and it was fine.

Either way, the run tonight is logging pretty much everything, so hopefully this will give me some more information.

Thanks for your help!

(10 Nov '10, 00:19) Calvin Allen

IIRC, I had some issues a while ago (with SA 10.0.1, can't remember the exact build) when using backup as part of a maintenance plan: AFAIK such a plan runs with the "WAIT BEFORE START" clause by default, and in case of (accidentally) long open trancactions, it prevented the backup to start at all... Manually removing that clause in the event handler solved the issue.

(10 Nov '10, 08:15) Volker Barth

@Volker - I can run the same statement without that clause, and it still acts the same.

(10 Nov '10, 15:08) Calvin Allen
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 09 Nov '10, 13:06

question was seen: 3,139 times

last updated: 08 Sep '11, 20:02