Hi All

I have done the following but get the PHP request_startup() for sqlanywhere module failed in Unknown on line 0 error:

FROM https://wiki.scn.sap.com/wiki/display/SQLANY/SAP+SQL+Anywhere+Database+Client+Download

wget http://d5d4ifzqzkhwt.cloudfront.net/sqla17client/sqla17_client_linux_x86x64.tar.gz
tar -zxvf /opt/sqlanywhere17/installation/sqla17_client_linux_x86x64.tar.gz -C /opt/sqlanywhere17/installation
/opt/sqlanywhere17/installation/sqlany17/setup
rm -rf /opt/sqlanywhere17/installation

Then get the client from https://wiki.scn.sap.com/wiki/display/SQLANY/The+SAP+SQL+Anywhere+PHP+Module

I've then copied the lib64 folder to /etc/SQLAnywhere/php73/lib64

I've added the extension to a file called sqlanywhere.ini in my conf.d folder: extension=/etc/SQLAnywhere/php73/lib64/php-7.3.0_sqlanywhere.so

I created a file called sqlanywhere.conf in /etc/ld.so.conf.d containing:

/opt/sqlanywhere17/lib64

And ran ldconfig

If I run "ldconfig -v" it shows all the various lib64 files for sqlanywhere

And then I restart the server and I get the "PHP request_startup() for sqlanywhere module failed in Unknown on line 0" error in my error logs

I've go this far but am absolutely stumped! Permissions? Apache not seeing the LDCONFIG? I'm really stuck and need to get a new server up asap! Any help appreciated!!

BTW I found this elsewhere on the forum but have no idea what file I would put this directive into

Adding: Environment=LD_LIBRARY_PATH=/opt/sqlanywhere17/lib64 at the beginning of [Service] section in the httpd.service file solved the problem in my case.

asked 17 May, 18:06

alunr's gravatar image

alunr
111
accept rate: 0%

BTW I am using Serverpilot for managing my server. These docs show how config needs to be done.

https://serverpilot.io/docs/customize-php-settings/

(17 May, 18:08) alunr

Also my database is on a remote machine so no need for running databases on this Linux install just the client.

(17 May, 18:13) alunr

Are you running php7.2-fpm? I had this problem and fixed it by adding the line

env[SQLANY17]=/opt/sqlanywhere17

to the file

/etc/php/7.2/fpm/pool.d/www.conf

(This was not required for sa 17.0.9.xxx)

(18 May, 08:58) Terry Wilkinson
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×62

question asked: 17 May, 18:06

question was seen: 75 times

last updated: 18 May, 09:00