Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.


As a result of running Schema Analysis > Run in SQL Central, I tried to move the database log file (Hades.log) to another volume as suggested. I use this command

/Applications/SQLAnywhere17/System/bin64/dblog -t "/Volumes//SQLAnywhere17Logs/Hades.log" "/Applications/SQLAnywhere17/databases/Hades.db"

I get these lines in the terminal:

SQL Anywhere Transaction Log Utility Version "/Applications/SQLAnywhere17/databases/Hades.db" was using log file "Hades.log" "/Applications/SQLAnywhere17/databases/Hades.db" is using no log mirror file

But when I start the database, the log file is still created at the place where the db file is located.

Any hint why it's not putting the log file to the specified volume?

And can I be sure that if the database log file is still at the same location, the database is in he same state as before running the command, i. e. nothing has changed?

SQL Anywhere macOS El Capitan Java 1.8.0_151

TIA, Robert

asked 10 Jan '18, 12:57

robert's gravatar image

accept rate: 0%

edited 10 Jan '18, 15:32

Breck%20Carter's gravatar image

Breck Carter

I would expect the output of dblog to include a line:

"Hades.db" is now using log file "<new log="" file="">"

If it does not, the log location will remain unchanged.

The command line you posted looks correct so I am not sure why it is not changing the log location.

(10 Jan '18, 13:45) Chris Keating
Replies hidden

Perhaps the double forward slashes are causing a problem: // in "/Volumes//SQLAnywhere17Logs/Hades.log"

(10 Jan '18, 15:35) Breck Carter
Replies hidden

Hi Chris

Thanks for your answer. Good to know there should be a line like "Hades.db" is now using log file <xy>. And no, there is no such line presented when executing the mentioned command. I also can't think of a sensible reason why it is behaving like this. I also could not find a log entry in the console related to this.

(11 Jan '18, 03:01) robert

Thanks for looking so clearly to my code! This double quotes are accidentally there, the command should of course be with only a single forward slash. I tried it with the correct command:

skyserver:~ admin$ /Applications/SQLAnywhere17/System/bin64/dblog -t "/Volumes/skyphos/SQLAnywhere17Logs/Hades.log" "/Applications/SQLAnywhere17/databases/Hades.db"
SQL Anywhere Transaction Log Utility Version
"/Applications/SQLAnywhere17/databases/Hades.db" was using log file "Hades.log"
"/Applications/SQLAnywhere17/databases/Hades.db" is using no log mirror file
skyserver:~ admin$

But the result is the same. No change of the log file.

(11 Jan '18, 03:41) robert

By the way, going it in SQL Central, I get the quite generic error message as seen in the attached screen shot.

Sorry, I can't upload a file (the screenshot). I get following error:

Error uploading file. Please contact the site administrator. Thank you. global name 'send_template_email' is not defined
(11 Jan '18, 04:10) robert

Strange. I checked on Windows, specifying a non-existing path for the log file issues a warning but does change the log location... So I don't know why you do not get a note about the new log usage here...

(11 Jan '18, 06:18) Volker Barth

I just tested this on a new install on OS X El Capitan.

I tested with a newly created demo database ( and

dblog -t "/users/home/newlog.log" "/Applications/SQLAnywhere17/samples/demo.db"

The log was successfully redirected to the supplied location.

This may be another issue that will require additional hands on investigation. Do you have support?

(11 Jan '18, 10:50) Chris Keating
Replies hidden

Thanks for testing on Windows, Volker. I also don't know why it does not work, unfortunately. The blog command seems to be correct in the second attempt. But still no change of log location.

(12 Jan '18, 03:55) robert

Thanks for testing. I have tried it on exact the same SQ Anywhere and macOS version (10.11.6). I have support for Windows, but not macOS yet.

(12 Jan '18, 03:57) robert

Sorry for the delay but I just saw this now. I will fix the "send_template_email" problem but the only reason it would get called when uploading a file is if the file was found to contain a virus. This could certainly be a false positive, and I just updated the virus scanner file just to be sure.

(16 Jan '18, 09:39) Graeme Perrow
showing 3 of 10 show all flat view
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 10 Jan '18, 12:57

question was seen: 1,395 times

last updated: 16 Jan '18, 09:39