Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.


I've installed sql anywhere 17 next to version 12 today and allthough I've tried to follow the steps in the guidelines, I've noticed that not everything is specified:

for example the mobilink server upgrade:

Once I install version 17, I still see the mobilink service pointing to the version 12 executable. So what I decided to do, is to modify this and point to version 17. When I start the service it seems to be working and I can synchronize, but there are a few strange things I'm noticing:

  1. When synchronising the remote server shows a message as following: "Subscription 'OneOfMySubscriptions' - Not Synchronizing - Log offset 0031853831 - Last download time xxxxxxx .... " => nevertheless The sync ends successfully and when I change something in the remote databas, this change ends up in the consolidated database.
  2. I have used the upgrade script as pointed out in the following link: , but first I tried to upgrade via Sybase central, (by clicking Check Mobilink System Setup) and here I got the following error: invalid sql data type -25

Thank you for your feedback !

asked 05 Apr '17, 10:29

vdcey's gravatar image

accept rate: 33%


There is usually more context around that error.

See what happens when you run the correct upgrade script using dbisql (or your DBMS-specific interactive sql utility). For upgrading from 12.0.1 you will need to find the script that matches your DBMS from this location

where you replace the correct string for your <DBMS>

If you were running with 12.0.0 make sure to use the 12.0.0 directory.

And if that also fails with that error again do note the line throwing that.

(05 Apr '17, 11:33) Nick Elson S...
Replies hidden


Thanks for your reply Nick. That's what I did. I ran the upgrade script for 12.0.1 directly in toad for oracle and it ran succesfully without any problems. Are you suggesting that I should try to click "Check Mobilink System Setup" again now?

(05 Apr '17, 12:40) vdcey

You shouldn't get an error unless you were accidentally using an older/mismatched Sybase Central (version 12 for example).

One thing that may matter is the ODBC driver you are using. Version 16 is only tested with the iAnywhere Solutions 16 ODBC driver for Oracle with an OCI client installation matching the Oracle server version. Do read over the Notes and Permissions settings.

When I google search for

      invalid sql data type "-25"

I get plenty of hits about Oracle's ODBC driver not supporting BigInts which would indicate you may be using an older and unsupported ODBC driver.

(05 Apr '17, 15:23) Nick Elson S...
Replies hidden

Thanks for the tip, I'll take a look at the driver. Can this error pose a problem in regular usage? since I've been able to run the upgrade script succesfully and have been able to synchronize data...

(06 Apr '17, 09:51) vdcey

If it is correct that Blobs lie at the root of this error, then there will likely be an issue if you have long binary columns or binary columns that are bigger than Oracle default buffer size.

There is always a chance that other problems might arise, given there has been no testing with that driver. For instance multiple different drivers [from Oracle and 3rd parties] we have historically seen issues with both long binary and long varchar data and some crashing issues.

(06 Apr '17, 09:58) Nick Elson S...

Unfortunately no luck. The ODBC driver that was being used was "iAnywhere Solutions 12 - Oracle" (MobiConn12), I added a new one based on "SQL Anywhere 17 - Oracle" (MobiConn17), now not only do I keep getting the same error but also can't sync anymore. Parameters: -c "dsn=MobiConn17" -v -o C:\Log\Mobilink\mls.txt -os 10m -cn 5 -zu+ -w 100 -ds 0 , getting a Consolidated database server or ODBC error : ODBC: [SAP][SQL Anywhere - Oracle][Oracle]ORA-06553: PLS-306: wrong number or types of arguments in call to 'DOWNLOAD_DELETE_CURSOR_NND'

(07 Apr '17, 08:44) vdcey
Replies hidden

> ODBC: [SAP][SQL Anywhere - Oracle][Oracle]ORA-06553: PLS-306: wrong number or types of arguments in call to 'DOWNLOAD_DELETE_CURSOR_NND'

Turn on verbose diagnostic logging mlsrv17 -v+ and then post the text before and after that error message.

(10 Apr '17, 08:28) Breck Carter
showing 4 of 7 show all flat view
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 05 Apr '17, 10:29

question was seen: 1,504 times

last updated: 10 Apr '17, 08:28