The forum is currently being migrated to a new host. While the migration happens, the old server is still available. Once the new machine is ready, I will copy the database to the new machine. Feel free to ask and answer questions in the meantime.

Hi,

We have some problems using external procedures (using CLR) on client's server. Actually, we do not have problem with the procedure itself, but with the external environment.

When I run the command "Start external environment CLR" in dbisqlc on my PC, there is no problem running it. But, when I run the same command on my client's server, I have the following error : "External environment cannot be started, external process terminated on start up". I tried many things but I could not find the source of the error. The file dbextclr16.exe is correctly located in the Bin32 directory and the .Net framework (2.0, 3.0, 3.5, 4.0) is correctly installed.

When I look in the Event Viewer of the server, I got the following report :

Fault bucket , type 0
Event NameĀ : CLR20r3
ResponseĀ : Not available
Cab Id : 0

Problem signature : P1 : dbextclr16.exe P2 : 16.0.0.19482 P3 : 539f5a00 P4 : dbextclr16 P5 : 16.0.0.19482 P6 : 539f5a00 P7 : 3a P8 : 16 P9 : System.IO.FileNotFoundException P10 :

Thanks for the feedback

asked 08 Mar '16, 14:50

francisbrochu's gravatar image

francisbrochu
16113
accept rate: 0%

edited 08 Mar '16, 15:12

Breck%20Carter's gravatar image

Breck Carter
31.3k5036891010


It's probable you are missing a required file. (dll, exe) Do make sure you have the neccessary .Net runtime installed, the documentation indicates you need to have a minimun version 3.5 CLR. dbextclr16.exe does require the .Net provider to be registered and needs some additional dlls.

If this doesn't help any, you may find you'll need to do some tracing of the failure and compare that to a running system. The old sysinternals ProcessMonitor or ProcessExplorer may help out to do some of that. There may also be some .Net CLR tools that may be useful.

Good luck.

permanent link

answered 08 Mar '16, 17:00

Nick%20Elson%20SAP%20SQL%20Anywhere's gravatar image

Nick Elson S...
7.3k35107
accept rate: 32%

converted 09 Mar '16, 10:29

Volker%20Barth's gravatar image

Volker Barth
37.1k343509770

Thanks for the tips. I fix the problem by running the following command on the client's server to fix the .Net assemblie : %SQLANY16%\Assembly\v2\SetupVSPackage.exe /install /salocation %SQLANY16%

(09 Mar '16, 10:12) francisbrochu
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×256

question asked: 08 Mar '16, 14:50

question was seen: 856 times

last updated: 09 Mar '16, 10:12