Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.


I have a setup where dbisql.exe fails to load. No GUI can be seen. Also, am not getting any error while running through double clicking or through command line.

  1. procmon dump (process monitor) from the system don't show any specific error.
  2. Event viewer logs also don't have any specific error for this.

The sybase version we are using is pretty old (9.0) and can't be upgraded. Is there anything I can do more to troubleshoot here?

Many thanks in advance.

Vineet link text

asked 13 Mar '14, 04:50

Vineet's gravatar image

accept rate: 25%

edited 13 Mar '14, 06:07

attached procmon result from the problematic system.

(13 Mar '14, 06:08) Vineet

Did it ever load properly? What changed since then?

Are you loading stuff from the network? Is there a security issue, or a firewall getting in the way?

FWIW there are a bunch of BUFFER OVERFLOW errors on the Java components including dbisqlg.exe.

Maybe there is a problem with the CLASSPATH. Version 9 was "early days" for the Java version of ISQL, and it pretty much sucked.

Look around for a crash dump file... although it looks like dbisql.exe ended "normally".

Workaround 1: Use the "C" version of ISQL: dbisqlc.exe

Workaround 2: Try executing dbisqlg.exe directly.

Workaround 3: Use the ISQL delivered with a later version of SQL Anywhere...

  -c "ENG=ddd9;DBN=ddd9;UID=dba;PWD=sql;CON=ddd9-2"
(13 Mar '14, 08:36) Breck Carter
Replies hidden

To All: Can anyone remember where V9 put its dumps and error logs and such like?

(13 Mar '14, 08:41) Breck Carter

This problem is occurring on only one setup having OS 2003 server. This works on all other setups with same OS version. Every thing is on the local machine.

We are calling dbisql.exe through scripts which are failing and no manual interference is there. This is happening on one setup.

I tried making one procmon dump from one of my working setup and tried comparing with the problematic one but no luck. I will attach the correct one for your reference.

At the time of problem, I tried opening dbisqlc.exe but got the same problem. Though, i was able to open ISQL through dbisqlg.exe


(13 Mar '14, 09:21) Vineet
Replies hidden
(13 Mar '14, 09:23) Vineet

I believe 9 writes error reports to the temporary directory (%SADIAGDIR%,%SATMP%,%TMP%,%TMPDIR%,%TEMP%, Current Directory). You could try running "dbisql -batch" which will save the java start line in a .bat file in the working directory. Sometimes you can see more detailed error messages by running this batch file instead of the executable.

(13 Mar '14, 11:01) Mikel Rychliski

Running dbisql.exe -batch command gives me isqlj.bat and asasrv.ini file. but running isqlj.bat file doesn't show anything. I tried running this on my working setup. Running through double click does nothing. Running through command prompt just print the command.

If I copy paste the command on the command prompt, its gives NoClassDefFoundError. All this happening on my working setup.

kindly let me know how to proceed fro here.

(13 Mar '14, 11:47) Vineet

The fact dbisqlc.exe does not work indicates the problem is much larger than just dbisql.exe not working, since dbisqlc.exe is a completely different animal.

If you haven't already, reboot. Try turning off all firewall and virus checkers on the local computer. If that doesn't help, reinstall ASA 9 ...those are just prerequisites to proceeding with other heroic measures :)

(13 Mar '14, 13:25) Breck Carter

"Every thing is on the local machine" that true? is the E: drive local, or a network drive?

Anyway, both procmon files show that dbisql.exe successfully launched dbisqlg.exe and then shut down, and that may be normal... you may be watching the wrong process; the problem may lie with dbisqlg.exe.

The procmon lines for dbisqlg.exe refer to different folders; is that a clue?


2:56:54.4754693 PM  dbisql.exe  3052    Process Create  
Command line: E:\NIC\4100\SIEM01~1\BIN\ASA\WIN32\DBISQLG.EXE


2:06:36.4104186 PM  dbisql.exe  1112    Process Create  
Command line: E:\NIC\4100\MYSITE~1\BIN\ASA\WIN32\DBISQLG.EXE
(13 Mar '14, 13:36) Breck Carter

dbisql_procmon.PML file i got from the problematic system. Logfile_correct.PML file i got from the working system. This i did to compare with dbisql_procmon.PML file.

(14 Mar '14, 02:56) Vineet

Yes, that was clear yesterday... did you read my comment above?

(14 Mar '14, 08:14) Breck Carter
More comments hidden
showing 5 of 11 show all flat view
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 13 Mar '14, 04:50

question was seen: 5,713 times

last updated: 14 Mar '14, 08:14