Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.


We are currently having an issue with a .NET application (developped in Visual Studio 2008). It is installed on a Windows 2003 Server R2, along with IIS 6.0.

The IIS login page loads fine, we enter the username and password, then hit "validate". This launches the connection to the database (Sybase 9.0.2 EBF 3221). As soon as it tries to connect, an error page appears with the folllowing error :

Server Error in '/Approbation' Application.

The 'ASAProv.90' provider is not registered on the local machine. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: The 'ASAProv.90' provider is not registered on the local machine.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: [InvalidOperationException: The 'ASAProv.90' provider is not registered on the local machine.]
System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper) +963332
System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection) +124 System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject) +86
System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup) +29
System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) +4863644
System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) +117
System.Data.OleDb.OleDbConnection.Open() +40 System.Data.Common.DbDataAdapter.QuietOpen(IDbConnection connection, ConnectionState& originalState) +31
System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +112
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +287
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, String srcTable) +92 System.Web.UI.WebControls.SqlDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) +1297
System.Web.UI.WebControls.SqlDataSource.Select(DataSourceSelectArguments arguments) +19
ApprobationWeb.Login.btnValidation_Click(Object sender, EventArgs e) in E:\Projets\Solidus-Poincon\Source\ApprobationWeb\Login.aspx.cs:49 System.Web.UI.WebControls.Button.OnClick(EventArgs e) +111
System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +110 System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13 System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565

We tried to register the two following sybase dll (dboledb9.dll and dboledba9.dll) on the server (we had the same error appear for another application last week (regular executable, not through IIS), we registered those and that fixed the issue for that application), but this did not fix the issue for our IIS application, we still get the same error. This is hapenning at one of our client's location. I installed this application with the same setup on a Windows Server 2003 R2 locally at our office and everything works perfectly. I also tried installing it on Windows XP on 3 different PC, they all work perfectly too.

I modified the IIS settings to use ASP.NET 2.0, and I also modified the permissions on the directory "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files" so that "NETWORK SERVICE" has full access to it.

I'm wondering if it's a permission issue, or somehow the dll are not properly registered, or could it be a dll missing in the assembly, etc.?

We're using ASAProv because our consultant (he's the one that designed this program, not me) tells me he could not view/use procedures in Visual Studio 2008, only functions and tables. With ASAProv he could see and use procedures.

Any help would be much appreciated. If you need more information, just let me know.

Thank you, Dominic Marcoux

asked 01 Apr '10, 19:21

Dominic%20Marcoux's gravatar image

Dominic Marcoux
accept rate: 0%

edited 15 Mar '13, 22:10

Mark%20Culp's gravatar image

Mark Culp

The 'ASAProv.90' provider is not registered on the local machine

Implies that the OLEDB provider cannot be located in the registry information - and sounds like you have registered it, at least for 32-bit applications (e.g. your application that is not IIS). Is this a Windows 2003 x64 installation? If so, IIS will be running as 64-bit - you would also need to register the ASAProv.90 x64 OLEDB provider for IIS to use this.

permanent link

answered 19 Mar '13, 08:25

Jeff%20Albion's gravatar image

Jeff Albion
accept rate: 25%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 01 Apr '10, 19:21

question was seen: 7,465 times

last updated: 19 Mar '13, 08:25