Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in August and this forum will be retired.

HI, I have tried to upgrade my Ruby 1.8.7 installation to 1.9.2 on Windows 7

I have installed the new versions of activerecord-sqlanywhere-adapter (1.0.0) and sqlanywhere (0.1.5 x86-mingw32)

When I try to run a rails server I get this:

=> Booting WEBrick
=> Rails 2.3.11 application starting on
in rescue in rescue in establish_connection': Please install the sqlanywhere adapter:gem install activerecord-sqlanywhere-adapter(no such file to load -- active_record/connection_adapters/sqlanywhere_adapter) (RuntimeError)
        from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activerecord-2.3.11/lib/active_record/connection_adapters/abstract/connection_specification.rb:73:inrescue in establish_connection'
When I try to run the test I get this:
C:TEMPCVS-Playgroundactiverecord-sqlanywheresqlanywhere>gem install sqlanywhere
Successfully installed sqlanywhere-0.1.5-x86-mingw32
1 gem installed
Installing ri documentation for sqlanywhere-0.1.5-x86-mingw32...
Installing RDoc documentation for sqlanywhere-0.1.5-x86-mingw32...

C:TEMPCVS-Playgroundactiverecord-sqlanywheresqlanywhere>ruby testsqlanywhere_test.rb c:/Ruby192/lib/ruby/gems/1.9.1/gems/sqlanywhere-0.1.5-x86-mingw32/lib/ [BUG] Segmentation fault ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

-- control frame ---------- c:0007 p:-10189070 s:0020 b:0020 l:000019 d:000019 TOP c:0006 p:---- s:0018 b:0018 l:000017 d:000017 CFUNC :require c:0005 p:0073 s:0014 b:0014 l:000010 d:000013 BLOCK <internal:lib rubygems="" custom_require="">:33 c:0004 p:0014 s:0011 b:0011 l:000010 d:000010 METHOD <internal:lib rubygems="" custom_require="">:29 c:0003 p:0059 s:0006 b:0006 l:001414 d:000634 EVAL test/sqlanywhere_test.rb:31

c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH c:0001 p:0000 s:0002 b:0002 l:001414 d:001414 TOP

-- Ruby level backtrace information ---------------------------------------- test/sqlanywhere_test.rb:31:in <main>' <internal:lib/rubygems/custom_require>:29:inrequire' <internal:lib rubygems="" custom_require="">:33:in rescue in require' <internal:lib/rubygems/custom_require>:33:inrequire'

[NOTE] You may have encountered a bug in the Ruby interpreter or extension libraries. Bug reports are welcome. For details:

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

Any help would be appreciated. Building sqlanywhere with rake tasks using the git repository and the latest ruby-devkit does not make a difference.

asked 17 May '11, 12:38

clst's gravatar image

accept rate: 0%

edited 17 May '11, 12:56

Graeme%20Perrow's gravatar image

Graeme Perrow

Are you using the Ruby distributions from RubyInstaller (

(01 Jun '11, 15:05) Eric Farrar
Replies hidden

Yes, those are the versions I tried.

(03 Jun '11, 12:42) clst

The name of the test file you tried to run is "testsqlanywhere_test.rb". The supplied test file in the project is named "sqlanywhere_test.rb". Are you running a modified version of the test file?

(08 Jun '11, 11:05) Eric Farrar

The crash appears to be happening right as the library is being loaded into memory. It seems that the Ruby environment is having trouble finding an entry point into the library. Have you had success building (and loading) any other native ruby libraries into your environment?

(08 Jun '11, 11:27) Eric Farrar
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 17 May '11, 12:38

question was seen: 3,091 times

last updated: 08 Jun '11, 11:27