Hello ,

I have problems connecting to a database (hsabiso2.db) via KNIME. The database is on a server in our network. For example, if I use access with Windows ODBC to connect to the database and its tables, from my (client) PC, this works without problems (I have admin rights).

SQL Anywhere 17 is installed.

[ODBC 32 bit Drivers] HSAB SQL Anywhere 17 (32 bit)=Installed [HSAB SQL Anywhere 17 (32 bit)] Driver=C:\Program Files (x86)\Hs\Ab\Sa17\Bin64\dbodbc17.dll Setup=C:\Program Files (x86)\Hs\Ab\Sa17\Bin64\dbodbc17.dll 32Bit=1

hsabiso2.dsf

DSN=HSAB_HSABISO2 Driver=HSAB SQL Anywhere 17 ServerName=hsab_isoloc_s_app02 DatabaseName= hsabiso2 CommLinks=TCPIP{} Integrated=NO MSApplications=YES

I have Integrated the driver sap. jdbc4. sqlanywhere. IDriver in the KNIME Database, because in KNIME Windows ODBC data sources is no longer supported out of the box.

But I don’t know the correct parameterization of the database URL “jdbc: sqlanywhere: .. .” I copied (and renamed) the database locally on my PC and tried that, but it doesn’t work with KNIME. But with Access the access works here too.

I got two errors:

(1) Execute failed: Could not create connection to database: Ungültiger ODBC-Handle or (2) Execute failed: Could not create connection to database: Connection to database ‘jdbc:sqlanywhere://C:\Users\MyUsername\Documents\HSDATENSICH\HSAB_HSABISO2_20210108_165405\HSABisotest.db’ timed out

I would like to say to myself that I am an absolute beginner. There is no JAVA knowledge, not even in SQL.

I hope I was able to explain the problem reasonably understandably.

Greetings from germany

asked 22 Jan, 03:14

USCHU70499's gravatar image

USCHU70499
112
accept rate: 0%

The SQLA JDBC url should be of the form:

jdbc:sqlanywhere:<connection_str>

Based on the DSN (line breaks after semicolons for readability)

jdbc:sqlanywhere:ServerName=hsab_isoloc_s_app02;
   dbn=hsabiso2;
   links=TCPIP;
   uid=<userid>;
   pwd=<pwd>

If you are trying to autostart the database on your machine with KNIME it would look like the following (set the <path> to the path for the database file): jdbc:sqlanywhere:ServerName=hsab_isoloc_s_app02; dbf=<path>\HSABisotest.db dbn=hsabiso2; uid=<userid>; pwd=<pwd>

(22 Jan, 09:00) Chris Keating

Hi Chris,

i work now with a local copy of the database hsabiso2.

New Url: jdbc:sqlanywhere:hsabisotest User name and Password are transferred separately in the KNIME DB Connector. I have to copy some dll and jar files in a new folder and then i had to specify this in the database preferences of KNIME when registering the driver.

It works!

I will try it now with your JDBC Url.

permanent link

answered 22 Jan, 09:25

USCHU70499's gravatar image

USCHU70499
112
accept rate: 0%

Hello Chris,

perfect - it works with your paramters too!

Thx !!

Greetings

(22 Jan, 09:31) USCHU70499
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15

question asked: 22 Jan, 03:14

question was seen: 128 times

last updated: 22 Jan, 09:31