Hi, Since I start using Windows 10, Sql central and Interactive Sql decided to use giant font for everything menu related. I'm using a 4k tv. After looking at other posts, I tries a few things: -Disable scaling -Playing with the compatibility settings didn't had any effects -Login without the tv connected did get the font a bit smaller, but not normal and after connection the tv, everything is a bit blurry. -Edit registry value in [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]

I'm out of idea... This is how it looke like: alt text

Thanks for the help!

asked 20 Jul, 09:28

girouxlp's gravatar image

girouxlp
66338
accept rate: 0%

Hi, What's your screen resolution and text size (both with and without a TV) in Windows display "Scale and layout" setting ?

To confirm, you have "disable display scaling ..." checked right now?

(20 Jul, 15:42) Evgeniya
Replies hidden

Hi, Thanks for replying. The tv resolution is 3840x2160, scale and layout is at 100%. Laptop screen is at 1920;1080, scale and layout is also 100%.

(20 Jul, 15:49) girouxlp

Can you please also attach a screenshot of your SQL Central's "Properties" -> "compatibility" -> "Change high DPI settings" tab.

(21 Jul, 13:51) Evgeniya
Comment Text Removed

I tried every combination in the shortcut properties compatibility tabs. I don't see a change high DPI setting tab. Do you mean a different place than this: https://i.imgur.com/BqEj7AK.png

Thanks again for the help!

(23 Jul, 09:45) girouxlp

I ran SQL Central on my Window 10 machine, with a 2560 x 1440 display. Here’s what I found:

  1. With a 225% text size scaling, and with the “Override high DBI scaling behavior” box unchecked, the fonts in SQL Central look about the right size. (That check box is on the "Compatibility" tab of the properties for the SCJVIEW.EXE file, as shown in the image from 23 July 2018.)
  2. Reducing the text size scaling to 100% and leaving “Override high DBI scaling behavior” unchecked gives the results we see in the image above: the menu text (“File”, “Edit”, etc) look OK, but the rest of the text in the application is too big.
  3. With text at 100%, checking “Override high DBI scaling behavior”, and setting the combobox under it to “Application” makes the menu text too large, but the rest of the text in the application is better – between 1.5x and 2.0x too large. But at least it’s legible.
  4. In a directory where you have permissions to write a file, run “scjview -XBatch”. This will create a file called scjview.bat which uses JAVA.EXE to run SQL Central. With the “Override high DBI scaling behavior” box unchecked, the fonts in SQL Central are much closer to expected size.

I would have to recommend you do the last thing – generate a batch file, and run that when you are using your 4K TV.

permanent link

answered 27 Jul, 15:11

ChrisIrie's gravatar image

ChrisIrie
29515
accept rate: 33%

Hi, I tried #4 and it sadly look the same with a 3840x2160 display... Thanks for the help.

(30 Jul, 09:41) girouxlp
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×106

question asked: 20 Jul, 09:28

question was seen: 1,676 times

last updated: 30 Jul, 09:41