Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.

I have an ASA 8 db file that I want to extract data from using linux (with command line).

I didn't find ASA 8 driver for linux, so I tried running the following command to unload the db to a new ASA db file version, so I can extract data from it with the newer ASA version that I do have (version 17).

unfortunately I got this error:


dbunload -an new.db -c "dbf=old.db;uid=dba;pwd=sql"


SQL Anywhere Unload Utility Version
Connecting and initializing
***** SQL error: Unable to start database server

I'm struggling with this problem for days, please help :)

asked 27 Oct '17, 11:09

gal's gravatar image

accept rate: 0%

1) Did you source the asa_config.[c]sh file before running your command? I.e. Is dbeng8 in your path?

2) Try starting the engine (dbspawn dbeng8 old.db) prior to running dbunload and then use -c "dbn=old;uid=dba;pwd=sql" as your connection string.

(27 Oct '17, 11:40) Mark Culp

I already ran but I cannot find dbeng8, where can I find it for linux?

(27 Oct '17, 12:20) gal

The dbunload utility should be able to read the ASA 8 database without starting a separate dbeng8 server... at least that's the way it works on Windows.

You may be able to convert the following Windows command file to Linux. It upgrades the ASA 8 demo database to SQL Anywhere 17:

REM If you're a command-line kinda guy, here is my template Windows 
REM batch file run_dbunload_upgrade_v8_to_v17.bat. It does the 
REM unload-reload-all-in-one-dbunload-step, then starts dbeng17 
REM and dbisql so you can make sure the new database is up and running.

REM Be sure to stop *all* database engines on the computer you're using, 
REM before starting the upgrade.

REM dbunload...
REM -an ...  where to put new database
REM -ap ...  new database page size
REM -c ...   old database startup connection string
REM -o ...   where to put unload console display text file
REM -v       verbose mode for console display


  -an asademo17.db^
  -ap 4096^
  -c "DBF=C:\Program Files (x86)\Sybase\SQL Anywhere 8\asademo.db;UID=dba;PWD=sql"^
  -o dbunload_log_asademo.txt^

PAUSE dbunload/reload done...

  -f "%SQLANY17%\bin64\dbeng17.exe"^
  -o dbeng17_log_ddd17.txt^

PAUSE dbeng17 started...

  -c "ENG=asademo17;DBN=asademo17;UID=dba;PWD=sql" 

PAUSE dbisql running...
permanent link

answered 27 Oct '17, 13:42

Breck%20Carter's gravatar image

Breck Carter
accept rate: 20%

On our windows machine we have a ASA 16 and we have tried to use the unload wizard but It did not work also we could not find dbunload.exe to test your script in the installation dir

(27 Oct '17, 14:49) gal
Replies hidden

The database utilities like dbunload should reside in the same subdirectory of the SA install as the database engine, namely bin32 or bin64. Could it be your installation is incomplete or has left out some components incidentally?

(27 Oct '17, 16:45) Volker Barth
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 27 Oct '17, 11:09

question was seen: 1,934 times

last updated: 27 Oct '17, 16:45