The forum will be unavailable for maintenance at some point from Friday, April 13 at 19:00 EDT until Sunday, April 15 at 23:59 EDT. Downtime will be minimized but the exact timing is unknown.

After upgrading from version -> (in the middle -> 16.0.02019, when trying to connect Sybase Central we received the following message:
“You are attempting to connect to a version 10 database running on version server. In order for Sybase Central to use this database, it must be unloaded and reloaded into a new database (Sybase Central only supports databases created by version 11 and later software)”
And it gives me the option to use the unload database wizard.

First, the database is files are fully upgraded (include the use of ALTER DATABSE command).
It seems that only Sybase Central affected by this, as we can connect through Interactive SQL without a problem.

Second, when trying to unload database we received the following error (tried from Sybase Central wizard and from command line using dbunload utility as well):
* SQL error: Invalid option 'timestamp_with_time_zone_format' -- no PUBLIC setting exists”

What can we do in order to:
a) Using Sybase Central
b) Unload database successfully

Thanks in advance,

Ohad Nir
DB Software Engineer
Allot Communications
Tel +972 09 7619245
Cell +972 58 6658096

asked 06 Sep '15, 11:29

onir's gravatar image

accept rate: 0%

The data type timestamp_with_time_zone and option "timestamp_with_time_zone_format" were introduced in version 12.

This may be due to a small (but undiagnosed) bug exposed by your upgrade sequence but you should try setting the public option and see if that is your only issue here.

Do let us know what your results with that change show.

For what it is worth, upgrades do not fully upgrade a database. Some features will require a rebuild (as in dbunload) ran from the newest version's utilities.

permanent link

answered 08 Sep '15, 12:13

Nick%20Elson%20SAP%20SQL%20Anywhere's gravatar image

Nick Elson S...
accept rate: 31%


Sorry for the late answer.
This actually solved the issue.
We set the option as follows:


thanks and best regards

(20 Sep '15, 03:41) onir
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 06 Sep '15, 11:29

question was seen: 1,775 times

last updated: 20 Sep '15, 03:41