Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.

Update at 9:08 AM EST August 6, 2015: This thread is unresponsive:

Update on August 3, 2015: It's still happening, on individual posts that have had recent activity.

Yesterday it happened on this post, right now it's happening on this post... they don't even open up.

Clicked on "Answer the question".

Saw "Waiting for"

Waited waited waited waited waited...

Abandoned the attempt (closed the page) after several minutes...

Redisplayed the forum home page.

Saw the message "You answered LoganTennis on How to list exceptions created in database via "CREATE EXCEPTION"".

Exclaimed "WooHoo! It worked!"

Clicked on the entry that now shows at the top, with "2 answers" instead of one "How to list exceptions created in database via "CREATE EXCEPTION""

Saw "Waiting for" again...

Posted THIS message, separately, no problems.

Still can't open the other one.

alt text

asked 27 Jul '15, 07:34

Breck%20Carter's gravatar image

Breck Carter
accept rate: 20%

edited 06 Aug '15, 09:09

...or you add a (particularly funny) comment to a question and that has been deleted in the meantime...

alt text

Seems to be a silent cascading delete, methinks:)

(04 Aug '15, 08:22) Volker Barth
Replies hidden

I posted and then deleted that question when I realized it was probably related to the SMTP server being used (because Foxhound had the same symptom as SA Monitor).

I do NOT remember adding a comment to that question, let alone editing that comment. I think there are some logic errors in the OSQA software, but I would rather Graeme tackle the performance issue first... AND none of these issues are showstoppers.

To put it bluntly, even if it's slow and buggy, THIS forum is better than anything SCN has to offer. Here, the problems are exceptions... over at SCN it's a surprise when anything works :)

(04 Aug '15, 14:12) Breck Carter

> silent cascading delete


(04 Aug '15, 14:14) Breck Carter

I have seen this frustrating behaviour on several occasions myself but I have been unable thus far to determine a cause. Restarting the Apache server solves the problem but that's a bit heavy-handed. I am still investigating.

Update: I have fixed the hanging problem. When you answer or comment on a question, the system automatically subscribes you to the question. The attempt to autosubscribe was hanging because another thread had already tried to do it but then hung around forever without doing a commit.

permanent link

answered 27 Jul '15, 08:54

Graeme%20Perrow's gravatar image

Graeme Perrow
accept rate: 54%

edited 07 Aug '15, 15:09

Ah, I thought moving to v17 with the change from SYSV to POSIX semaphores might do the trick - dogfooding, y'know:)

(27 Jul '15, 09:14) Volker Barth
Replies hidden
Comment Text Removed

> a bit heavy-handed

Until you have the inevitable epiphany, I would gladly trade an occasional 404 Not Found for the endless "Waiting" messages... at least I would know what to do.

Running a chron job to reboot Apache once (or two or ten) times a day would improve the current user experience.

Remember, this isn't a nose-cone computer, or an embedded defibrillator, or, it's a lightly-loaded Q&A site.

Plus... I'll bet Apache comes up pretty fast.

I have personal knowledge of a financial institution that used to reboot their SQL Anywhere 9 international money transfer SQL Remote consolidated database once a day to eliminate "unresponsive server" problems... they were very happy with their workaround.

(27 Jul '15, 13:35) Breck Carter
Replies hidden

Great, so now Linux Apache gets the same advice as Windows was used to get: reboot from time to time.

(28 Jul '15, 07:57) Martin

The SYSV to POSIX move was largely to combat problems with Apache, it's true. Apache just kills processes sometimes, and we were running into a lot of issues with leaked SYSV semaphores, particularly within the PHP driver. There is a global system limit to these semaphores, and so eventually new connections would just fail. POSIX semaphores (the ones we are using, anyway), are contained within shared memory in files on disk, so they don't have a leakage problem (we unlink the file as soon as we create it so that it goes away once the process is killed), and they don't have a global system maximum to speak of (technically, inodes are limited on a file system).

HOWEVER, I don't think that this is likely to be the problem here. The SYSV semaphore limits should cause all new connections to fail. This appears to be one page at a time. Furthermore, the only way to fix the problem would be to manually ipcrm all of the leaked semaphores (or reboot the server). If simply restarting Apache fixes the problem, then I doubt it has anything to do with SYSV semaphores.

But maybe Graeme will prove me wrong when he upgrades the server.

(28 Jul '15, 13:53) Phil Mitchell

What was I thinking? I'll just stop posting until the correct solution is found! Thanks!

alt text

(28 Jul '15, 20:59) Breck Carter

Well, your choice, apparently - have fun and relax...:)

I'm not sure whether I would take that approach to wait for correct solutions within the SCN/SAP marketplace - might turn your holiday into retirement:)

(29 Jul '15, 04:11) Volker Barth

Phil, thanks to the detailed explanation - frankly, I had simply seen a link between the new POSIX semaphores in v17 and Graeme's earlier reports of SYSV semaphore problems with Apache on this forum so that was really a very wild guess on my part:)

(FWIW: I have just noticed your serious comment now - somewhat buried beneath those fun posts...

(03 Aug '15, 15:30) Volker Barth

> prove me wrong

Nope, that didn't happen, alas... the "one page at a time" going unresponsive is still happening after the weekend upgrade to V17... I would cheerfully [redacted] to get a look at Foxhound running against the database... no, wait, Foxhound doesn't run against V17 yet, drat! :)

(03 Aug '15, 16:09) Breck Carter

It's actually worse now... a brand-new fresh reply (no edits etc) makes a thread go unresponsive immediately, before the acknowledgement is received.

The only way I know the reply was accepted is this thank-you note appears when the website is opened in a new tab "You answered WIHank on SQL Anywhere 12 Informatica ODBC.ini settings"... can't open the question, though.

I can't believe this symptom has anything to do whatsoever with SQL Anywhere. I think it's the crappy open source software... you get what you pay for.

(03 Aug '15, 21:07) Breck Carter
Comment Text Removed

> I have fixed the hanging problem.

Was the fix made to OSQA client application code?

BTW... hooray! :)

(08 Aug '15, 09:09) Breck Carter
Replies hidden

Yes, it was a problem in the OSQA code.

(08 Aug '15, 10:55) Graeme Perrow
showing 4 of 11 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 27 Jul '15, 07:34

question was seen: 1,451 times

last updated: 08 Aug '15, 10:55

Related questions