Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.

Can one control the font size in Sybase Central? I'm installing SQLA on a machine that has one of these new-fangled high resolution but small size screens (13" 3200 x 1800). Some Windows apps have the problem that the font is too small to read - but Sybase Central is going the other way and making the font (in most places) far too large!

While there seems to be some control of font size in ISQL, I can't see anything for Sybase Central (looking at the v11 and v16 versions)

alt text

asked 17 Oct '14, 15:02

Justin%20Willey's gravatar image

Justin Willey
accept rate: 20%

edited 28 Jul '16, 08:08

Thomas%20Duemesnil's gravatar image

Thomas Dueme...

WAG: Muck around with Windows settings for the Sybase Central shortcut using right-mouse - Properties - Compatibility tab...

...can't imagine it looking any worse :)

permanent link

answered 17 Oct '14, 17:23

Breck%20Carter's gravatar image

Breck Carter
accept rate: 20%

It's not a bug it's a feature - just fitting for us old-timers facing presbyopia:)

(18 Oct '14, 08:00) Volker Barth
Replies hidden

> presbyopia

The inability to focus on Presbyterians? :)

(18 Oct '14, 08:17) Breck Carter

@Breck - That works - or at least it changes the font size from "unsusably large" to "too small to read without a magnifying glass" - but that is just Volker's problem with Presbyterians kicking in I fear. I'll just get out the magnifying glass.

The relevant setting is "Disable display scaling on high DPI settings" which should be ticked to get the smaller font size.

(19 Oct '14, 17:49) Justin Willey

Interestingly - while the compatibility switch works for v16 it has no effect in v11

(23 Oct '14, 13:54) Justin Willey

I have changed that for Sybase Central. That looks Ok now. But i seams not to work for dbisql.exe when i start it from commandline. When I start it from Sybase Central it looks much better. I Supsect that SAP doesn't care. This is for Version

(28 Jul '16, 08:04) Thomas Dueme...
Replies hidden

My Fault. It works as described here but if you let the quick launcher run when yu change the settings ..... Anyway I would vote for a cleaner sollution out of the box. Anybody knows if this is fixed in SA17 ?

(28 Jul '16, 08:12) Thomas Dueme...
showing 4 of 6 show all flat view

Start the laptop or PC w/o connecting the screen. Open Sybase Central and fonts are normal. Now, connect and start the 4k screen. Fonts will display as normal. If you are going 4k w/o scaling make sure its at least 40" and supports 60hz update rate. Run CPU-Z to check your screen card. For me a Phillips 40" 4k w/displayport and Dell Precision M6700 w/o docking station did the trick. I'd guess 60 hz will be a must to avoid scaling and fuzzy fonts.

permanent link

answered 15 Feb '17, 04:45

beemray's gravatar image

accept rate: 0%

Had the same issue with a Surface Book 2. Changing the DPI settings helped a bit. When using a Surface Dock and 32 inch screen SQL Central was unusable. You are correct, disconnecting the dock, opening SQL Central and then reconnecting the dock is the only way to resolve this. It's still massive compared to other apps, but at least useable.

(05 Nov '18, 17:09) gchq
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 17 Oct '14, 15:02

question was seen: 42,504 times

last updated: 06 Dec '22, 18:11