Please be aware that the SAP SQL Anywhere Forum will be shut down on August 29th, 2024 when all it's content will be migrated to the SAP Community.


I am trying to get sync running for a new customer. I took a version 9 database, cleaned it up and setup sync on it. I ran syncsa.sql manually on the database and then setup all my scripts. Now when I start up mlsrv I get the following errors. Nor sure where to go with this to fix? Thanks.

E. 2014-05-22 14:28:30. <main> [-10002] Consolidated database server or ODBC error: ODBC: [Sybase][ODBC Driver][SQL Anywhere]Table name 'ml_user' is ambiguous (ODBC State = 42S13, Native error code = -852) E. 2014-05-22 14:28:39. <main> [-10100] The MobiLink system table 'ml_user' is missing or a table column is missing I. 2014-05-22 14:28:39. <main> Shared administrative connection with connection ID 'SPID 16' has been disconnected E. 2014-05-22 14:28:39. <main> [-10382] The MobiLink Server has failed to start

asked 22 May '14, 16:30

jimblackburn's gravatar image

accept rate: 0%

Before version 10, SQL Anywhere databases had a built-in MobiLink system setup by default; there was no syncsa.sql. My guess is that the problem is due to running a v16 syncsa.sql against a v9 database (that already had the built-in v9 ML system setup).

Since you have SQL Anywhere 16, why not upgrade the v9 database (or a copy of it, at least to test) to version 16?

permanent link

answered 22 May '14, 16:53

Graham%20Hurst's gravatar image

Graham Hurst
accept rate: 29%

I did upgrade the database to 16 before I started setting up ML. When I started setting up ML I got an error that I need to manually run the ML consolidated setup script syncsa.sql because ML had some version 9 components. I did that without any errors and now I have this problem. I am thinking about dropping all the ml* tables and starting over.

(22 May '14, 17:24) jimblackburn
Replies hidden

Here are the upgrade instructions for versions earlier than 10:

In your case, it may be enough to drop the ml_* objects owned by dbo. (If you had never used MobiLink with the v9 database, the upgrade should have dropped those objects, but apparently they had been used.)

(22 May '14, 17:50) Graham Hurst

The update didn't help as well so I started over from my first v16 update and deleted all the dbo.ml_ tables and SPs and setup the database as a consolidated db and mssrv16 works now. On to the next problem :). Thanks.

permanent link

answered 22 May '14, 18:51

jimblackburn's gravatar image

accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 22 May '14, 16:30

question was seen: 1,742 times

last updated: 22 May '14, 18:51