Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Upon Breck Carter request I am posting a new question. I can not reproduce this issue in SA or later, in other words after SQL Anywhere switched to OpenSSL everything works fine, but SQL Anywhere is the version I need to be able to communicate with SOAP web service.

This is the function I use to get data from a webservice:

CREATE FUNCTION WebServiceCall(in wsurl varchar(2048), in wsns varchar(2048), in cert varchar(2048),
    in username varchar(128), in password varchar(128), in idnum varchar(128), in productNumber varchar(128), in lang varchar(128))
url '!wsurl' type 'SOAP:DOC' namespace '!wsns' certificate 'cert=!cert' set 'SOAP(op=GetSaisWithPdf)';

Calling it I get this error:

There was an error reading the results of the SQL statement. The displayed results may be incorrect or incomplete. HTTP request failed. Status code '0' SQLCODE=-983, ODBC 3 State="HY000"

And this is what I get in the log file (sensitive data is hidden, sorry for that):

[connid = 18, 04/02 13:41:05.315]
[connid = 18, 04/02 13:41:05.315, REQUEST]
POST /***/SAIS/WebServices/getsais.asmx HTTP/1.0
Content-Type: text/xml; charset=windows-1257
Connection: close
ASA-Id: 26edeefbd1c2403f9210fb4554217ad4
Content-Length: 528
Accept-Charset: windows-1257, UTF-8, *
Date: Wed, 02 Apr 2014 10:41:05 GMT
Host: ***
SOAPAction: ""
User-Agent: SQLAnywhere/

<?xml version="1.0"?>
[connid = 18, 04/02 13:41:33.568, RESPONSE]
[connid = 18, 04/02 13:41:33.573, RESPONSE]
TTP/1.1 200 OK
Cache-Control: private, max-age=0
Content-Type: text/xml; charset=utf-8
Server: Microsoft-IIS/8.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
S: 1
Date: Wed, 02 Apr 2014 10:41:32 GMT
Connection: close
Content-Length: 1207257

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd=""><soap:Body><GetSaisWithPdfResponse xmlns=""><GetSaisWithPdfResult><XmlDocument><root xmlns=""> <InfoBlock name="tblInfoBlock" title="Santrauka" sectionId="santrauka"> </InfoBlock><Summary name="tblSummary" UnknownValue="Nenustatyta"> <vat Name="Vėlavimo atsiskaityti reitingas" Probability="83,00%" ProbabilityText="tikimybė," ClassValue="10" ClassText="klasė," ClassName="Aukščiausia rizika" IsSet="true" /><bt Name="Bankroto reitingas" Probability="5,033%" ProbabilityText="tikimybė," ClassValue="8" ClassText="klasė," ClassName="A
[connid = 18, Protocol Error]
[connid = 18, socket closed]
[connid = 18, Error: socket closed by peer]

As you can see, the response is truncated to 1024 characters, I contacted the web service maintainers and they confirmed that they send out the full response, I tried the same request (envelope generated by SA) in SoapUI and in C# and got correct results, no truncation. Also, as mentioned before, it works perfectly with latest SA12 EBF. So any ideas whats wrong? I tried reading the EBF release notes but could not find anything related to my problem.

asked 02 Apr '14, 06:51

Valdas's gravatar image

accept rate: 83%

edited 02 Apr '14, 06:52

This issue has been fixed in CR #764411 in the following builds: v16.0.1925, v12.0.1.4119, v11.0.1.3156 (or higher).

permanent link

answered 22 May '14, 15:09

Mark%20Culp's gravatar image

Mark Culp
accept rate: 41%

edited 23 May '14, 07:13

Jeff%20Albion's gravatar image

Jeff Albion

When will be v11.0.1.3156 available to download?

(27 May '14, 02:18) Arthoor
Replies hidden

The SP got added to the QA queue last week to be tested... so it is hard to tell at this point when it will be available. My guess would be a few weeks depending on how the testing goes. Note that 11.0.1 is EOL as of the end of this week so this will be the last SP for 11.0.1.

(28 May '14, 09:19) Mark Culp
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 02 Apr '14, 06:51

question was seen: 5,084 times

last updated: 28 May '14, 09:19