Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

Hi, Am new to Sybase products, and when I tried to install SQL Anywhere dev edition 16, I get below error message:

./setup: line 17: csconvert: command not found ./setup: line 33: dbinstall: command not found

which: no dbinstall in (/home/oracleuser/sa16developerlinux/ga1600/./binInternal error: Unable to execute dbinstall:/bin:/usr/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/oracleuser/bin:/bin:/sbin:/usr/bin:/usr/sbin:/opt/usr/bin:/opt/usr/sbin:/usr/local/bin:/usr/local/sbin) ERROR: The "/home/oracleuser/sa16developerlinux/ga1600/admintools.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/admintools.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/admintools.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/deploywizard.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/encryption.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/encryption.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/encryption.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/extended.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/extended.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/extended.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/jre.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/jre.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/langres.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/php.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/php.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/readme.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/sqlany.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/sqlany.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/sqlany_base.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/sqlany.noarch.tic" "/home/oracleuser/sa16developerlinux/ga1600/synch.32.tic" "/home/oracleuser/sa16developerlinux/ga1600/synch.64.tic" "/home/oracleuser/sa16developerlinux/ga1600/synch.noarch.tic" seems to be corrupted. Please report this problem to Sybase Technical Support.

Could anyone let me know how to correct this problem? My machine is - Linux localhost.localdomain 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Thanks in advance, Vaish

asked 14 Nov '13, 22:42

Vaish's gravatar image

accept rate: 0%

edited 14 Nov '13, 22:50

Mark%20Culp's gravatar image

Mark Culp

Which distro of Linux are you using? and what version?

Have you verified that your download was not corrupted? Did you properly unzip/untar'ed the install?

Due to the errors that you have posted it would imply to me that the files did not get downloaded/untar'ed correctly.

FWIW the csconvert and dbinstall programs should be in the installation's subdirectory called 'bin' (i.e. the first directory in the path: /home/oracleuser/sa16developerlinux/ga1600/./bin) - if they are not there then something or some step has gone wrong.

(14 Nov '13, 22:49) Mark Culp
Replies hidden

Hi Mark Culp, Am using Linux X86 and 64 distribution and version is SAP Sybase SQL Anywhere 16 Developer Edition.

After your response, I have copied all the files in bin64 folder to /usr/bin/ . And now the setup is starting, but am getting the error message "csconvert: error while loading shared libraries: /usr/lib64/ file too short".

Could you kindly let me know how to rectify this problem.

Thanks, Vaish

(14 Nov '13, 23:31) Vaish

You should not need to copy any files from the install into /usr/bin (or any place else). The install changes the PATH with in the install script (i.e. setup) so that the tools will be found while the script is running.

The fact that the 'file too short' error is being reported again makes me believe that either the download or the installed files got corrupted. For example, did you FTP the file(s) from one machine to another in non-binary mode (this is a common problem that we see a lot).

I would suggest that you start by downloading the install from Sybase/SAP again, clean up (remove) any existing files that you have copied into your /usr/bin and /usr/lib64 directories, and then try again.

BTW: You did not indicate which version/distro of Linux you are using. This information may be helpful because we know that there have been problems on some distros in the past.

(15 Nov '13, 08:04) Mark Culp

Hi, Spot on.. I did FTP in auto mode and now I tried with binary mode and there is no error. Installation is successful. Thanks a lot for your reponse. Note: My linux version - Red Hat Enterprise Linux Server release 5 (Tikanga)

(17 Nov '13, 18:54) Vaish

I think you need to install the architecture x86 (x86 libs).

permanent link

answered 15 Nov '13, 00:20

Marsel's gravatar image

accept rate: 33%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 14 Nov '13, 22:42

question was seen: 4,293 times

last updated: 17 Nov '13, 18:54