Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

i'm trying to connect an XP 32bit laptop over a WAN to an ASA11 db. the pc sees shared folders on the db server via explorer.

i'm using the Windows ODBC manager to set up the connection. because it's on a different sub net than the server, on the network tab in ODBC setup , i'm specifying host= with different tries at specifying a port and DoBroadcast=Direct.

examples of what i've tried are host=...:port=2638, host=...;port=2638, host=...:2638;DoBroadcast=Direct (all lower, mixed case, and all upper).

i've tried the DoBr at the beginning of the line (DoBr..;host-...) with and without a port specified.

when the laptop is on the LAN in the main office, it connects.

any help would be appreciated.

asked 08 Jan '13, 17:59

Tom%20Mangano's gravatar image

Tom Mangano
accept rate: 8%

edited 08 Jan '13, 18:05

If the port number that the server is using is 2638 (the default), you don't need to specify port= at all. If you're specifying a host IP address, the default is DoBroadcast=direct so you don't need to specify that either. In the network tab, make sure the TCP/IP box is checked and specify host= in the text box next to it. You also need to make sure you have the correct server name on the Database tab.

permanent link

answered 08 Jan '13, 18:43

Graeme%20Perrow's gravatar image

Graeme Perrow
accept rate: 54%

edited 08 Jan '13, 18:43

something has changed on the laptop or with the ISP, because host=172... worked in Oct 2012 for about 4 weeks. we can't figure out what has changed.

the tech i was working with on the other end and i thought it was something to do with a firewall or something the ISP provider was blocking.

a further test, using telnet (telnet 2638) came back successfully.

the message we get is dbserver not found. if the company hit its connection limit while we were trying to connect, would we get a different message?

(08 Jan '13, 19:10) Tom Mangano
Replies hidden

yes, you would get a license exceeded message

(09 Jan '13, 03:11) Martin

the telnet IP is different than the IP you mentioned in your question above?

(09 Jan '13, 03:11) Martin

the ip address i used in my example was a number i made up because i couldn't remember the actual addr. the one in the telnet is the one we used for host= on the network tab.

(09 Jan '13, 04:47) Tom Mangano

Thanks for the suggestions.

The client was able to connect with host=, which what was originally in his setup that STOPPED working.

AFAIK, no other changes were made to their VPN, firewall, network, etc.

(17 Jan '13, 07:32) Tom Mangano
Replies hidden

In this case don't trust the statement that nothing else was changed ;-)

(17 Jan '13, 10:14) Martin
showing 3 of 6 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 08 Jan '13, 17:59

question was seen: 2,142 times

last updated: 17 Jan '13, 10:14