Please be aware that the content in SAP SQL Anywhere Forum will be migrated to the SAP Community in June and this forum will be retired.

I have a client who has software that uses a Sybase SQL Anywhere 6.0? database. He has sent the .db file to me. I have downloaded and installed the SQL Anywhere 10.0 Developer edition in an attempt to convert this db file to a 10.0 compliant file so that I can load it up into a server so that I can then test my MS Access application to the sybase database.

However, the problem is that when I click on the "Prepare a version 9 or earlier database for SQL Anywhere 10" and go through the wizard, I get an error message that states:

*SQL error: Unable to start database server: Server fatal error. The database....could not be unloaded The database....could not be unloaded

Am I missing something obvious?

Thanks in advance for any help anyone can provide.

asked 07 Jan '13, 20:14

Voyagr12's gravatar image

accept rate: 0%

edited 15 Mar '13, 20:37

Mark%20Culp's gravatar image

Mark Culp

There was a problem with trying to unload files from pre-v10 databases that needed recovery before they could be started by the engine used by v10, however this was fixed some time ago (in v10.0.1.3917). Is the v10.0.1 you are using later than that? If not, either apply the latest ebf to your engine or get your client to start and then stop the v6 db and then send you the .db and .log file. That should give you a clean start.

If you are using a later v10 engine, it would be still worth trying to start the db file you have under v6 just to make sure there is no issue with it.

permanent link

answered 08 Jan '13, 06:15

Justin%20Willey's gravatar image

Justin Willey
accept rate: 20%

edited 08 Jan '13, 06:16

Thanks for the response.

I have updated my Sybase Central to v10.0.1.4310 and I still get the same problem with the "Prepare a version 9 or earlier database for SQL Anywhere 10" command.

Unfortunately, I do not have v6 and from what I can tell, Sybase no longer offers this version for download. Do you know of a location?


(08 Jan '13, 09:31) Voyagr12
Replies hidden

How big is the database? Is the content confidential? I have v6 installed so I might be able to tell you want is wrong with the db!

(09 Jan '13, 12:45) Justin Willey

Thanks Justin! I will get back to you on that. I will get with my client. Can you legally provide me with an installation of v6? I know the developers editions of 10, 11 and 12 are freely available. Thanks!

(09 Jan '13, 13:14) Voyagr12

I guess I should also confirm that I am headed in the right direction with this. I want to connect MS Access to the Sybase .db file so that I can use the data contained within. To do that I need to use ODBC. To do connect via ODBC the Sybase .db file needs to be running in a server? are these assumptions correct?

...actually, for development purposes I could simply import all the tables from the .db file into the MS Access. I dont need live connection for development purposes.

(09 Jan '13, 13:19) Voyagr12

One more item...the db is 735 a bit large.

(09 Jan '13, 13:20) Voyagr12

Yes, you need to run a server to access the data. Kinda obvious ;).

(10 Jan '13, 06:36) Dmitri

I don't think I can. A developer edition of v9 would do, but as you say that isn't available either.

Your client must have a v6 db engine if he is able to connect to the database - you can't connect except through a server.

Breck's question about how the copy of the db was made is very relevant. If the db is currently running, then a properly made online backup (or a copy of the db & log file when the dbengine is closed down) should start fine under Breck's process.

(10 Jan '13, 09:22) Justin Willey

Not too obvious if one is used to a server-less DBMS (should I put that in quotes?) like MS Access...:)

(10 Jan '13, 09:47) Volker Barth
showing 1 of 8 show all flat view

I guess I am on my own with this one. Perhaps I will just abandon working with sybase and stick to SQL Server and MS Access. Thanks.

permanent link

answered 09 Jan '13, 12:37

Voyagr12's gravatar image

accept rate: 0%

Edit the following command file, and try it on your V6 *.db file. If it gives the same error, post the output *.txt files here...

REM If you're a command-line kinda guy, here is my template Windows 
REM batch file run_dbunload_upgrade_to_10.bat. It does the 
REM unload-reload-all-in-one-dbunload-step, then starts dbeng10 
REM and dbisql so you can make sure the new database is up and running.

REM Be sure to stop *all* database engines on the computer you're using, 
REM before starting the upgrade.

REM Watch out for wrapped lines in the newsgroup display...

REM dbunload...
REM -an ...  where to put new database
REM -c ...   old database startup connection string
REM -o ...   where to put unload console display text file
REM -v       verbose mode for console display


"%SQLANY10%\win32\dbunload.exe" -an ddd10.db -c "DBF=ddd6.db;UID=dba;PWD=sql" -o dbunload_log_ddd6.txt -v
PAUSE dbunload/reload done...

REM dbeng10...
REM -c ...    initial RAM cache size
REM -o ...    where to put server console display text file
REM -os ...   when to rename and restart server console display text file
REM -x none   speed startup by disabling client protocols except shmem
REM ddd10.db  new database to start

"%SQLANY10%\win32\dbspawn.exe" -f "%SQLANY10%\win32\dbeng10.exe" -o dbeng10_log_ddd10.txt ddd10.db 
PAUSE dbeng10 started...

REM dbisql...
REM -c ...   new database connection string

"%SQLANY10%\win32\dbisql.exe" -c "ENG=ddd10;DBN=ddd10;UID=dba;PWD=sql" 
PAUSE dbisql running...
permanent link

answered 09 Jan '13, 15:01

Breck%20Carter's gravatar image

Breck Carter
accept rate: 20%

edited 09 Jan '13, 15:01

This is what was displayed in the dbunload_lob_dd6.txt file:

SQL Anywhere Unload Utility Version Connecting and initializing * SQL error: Unable to start database server: Server fatal error

(09 Jan '13, 15:17) Voyagr12
Replies hidden

Chances are the database file is unusable. You could try using Version 12 instead of 10, and if that has the same problem then you should call Tech Support

(09 Jan '13, 16:20) Breck Carter

I have tried 10, 11, and 12 with no luck. At least through the sybase central. The client can connect just fine but he has v6 of the driver I believe. I dont think he has the full version as this is just a backend to another application he has. I currently am having him import into a MS Access database so that I can at least see the data structure and data.

Thanks for your help. If nothing else, I will need to contact sybase support. Do they monitor these forums?

(09 Jan '13, 16:32) Voyagr12

ASA is a datbase server, so yes, you need server to access data (versions 6 thru 9 in your case). And, to be honest, V6 is way too old to be of any interest today ;).

(10 Jan '13, 06:34) Dmitri

How did the client create the copy of the *.db file? Did they stop the SQL Anywhere 6 server and make a file copy, or did they use some other technique? (other techniques sometimes result in bad copies).

(10 Jan '13, 07:43) Breck Carter

I believe the client sent me the backup file that the system generates every night.


(12 Jan '13, 18:52) Voyagr12
showing 1 of 6 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 07 Jan '13, 20:14

question was seen: 5,147 times

last updated: 15 Mar '13, 20:37