how to start the multiple instances of mobilink server on a same machine with different Port?

I have tried using tcpip(port=2440) and its giving me a syntax error near (


asked 09 Dec '12, 21:27

vhm's gravatar image

accept rate: 0%

Please post your full command-line (excluding passwords) so we get the full picture.

  • Russ
permanent link

answered 09 Dec '12, 21:42

RussC_FromSAP's gravatar image

accept rate: 18%

. /opt/sqlanywhere10/bin32/mlsrv10 -c "DSN=SQLANY" -zs Rmlsvr -fr -zu+ -f -zp -x tcpip(port=2440) -ud -w 10 -wu 5 -cm 250M -cn 30

(09 Dec '12, 21:45) vhm

Try using {} instead of () as in: -x tcpip{port=2440}

(09 Dec '12, 22:18) RussC_FromSAP

i am getting command not found if I try with {}

(09 Dec '12, 22:22) vhm

Ah, I'm looking at how our test gear works and I see I missed a subtle point. You have to put double quotes, as follows: -x "tcpip{port=2440}".

  • Russ
(10 Dec '12, 00:03) RussC_FromSAP

still the same and getting following message

-bash:ELF: command not found

(10 Dec '12, 01:46) vhm

OK. I googled the "ELF" error, and there is another subtle point. Your command line has ". " in front of the mlsrv10 path. This means that you are attempting to invoke an executable as a shell script. Remove the leading ". ".

  • Russ
(10 Dec '12, 11:05) RussC_FromSAP

it works !! thanks Russ

(11 Dec '12, 00:49) vhm
More comments hidden
showing 5 of 7 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 09 Dec '12, 21:27

question was seen: 1,099 times

last updated: 11 Dec '12, 00:49