The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

Feeling a bit lost on this one, I am simply trying to set the RequestLogMaxSize option under SA 12 using sa_server_option:

call sa_server_option('RequestLogMaxSize','20k')

No matter how I format it or change it, I get "Invalid setting for option 'RequestLogMaxSize'" (unless I specify zero). I'm able to set it using -zs.

What am I missing? Am I not able to set it using the stored proc?

asked 17 Jan '12, 18:06

Dan%20Hacker's gravatar image

Dan Hacker
1765513
accept rate: 0%


It appears that the server option is specified in bytes, making the 'k' suffix of the size an invalid input:

sa_server_option system procedure

If you execute the procedure as:

CALL sa_server_option('RequestLogMaxSize',20480);

It will work correctly. The k/m/g suffixes are interpreted as necessary from the command line parser.

permanent link

answered 17 Jan '12, 18:16

Tyson%20Lewis's gravatar image

Tyson Lewis
2.2k1641
accept rate: 22%

Oh my gosh, you are right. It has to be entered exactly as you specified. I was simply entering 20000 to test without the quotes and the 'k'.

(17 Jan '12, 18:20) Dan Hacker
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×11

question asked: 17 Jan '12, 18:06

question was seen: 549 times

last updated: 17 Jan '12, 18:20