I am trying to understand what the "404 Not Found" message in the RSOE log file applies to: the log indicates the RSOE has found the Relay Server.

SQL Anywhere 11.0.1.2652
IIS 6.0

I. 2011-09-03 18:52:07. iAnywhere Outbound Enabler Version 11.0.1.2652
I. 2011-09-03 18:52:07. 
I. 2011-09-03 18:52:07. Copyright © 2011, iAnywhere Solutions, Inc.
I. 2011-09-03 18:52:07. Portions copyright © 2011, Sybase, Inc. All rights reserved.
I. 2011-09-03 18:52:07. Use of this software is governed by the Sybase License Agreement. Refer to http://www.sybase.com/softwarelicenses
I. 2011-09-03 18:52:07. 
I. 2011-09-03 18:52:07. <OEHost> [Outbound Enabler]
I. 2011-09-03 18:52:07. <OEHost>   verbosity = 5
I. 2011-09-03 18:52:07. <OEHost>   farm = AbInterfaceMobiLinkFarm
I. 2011-09-03 18:52:07. <OEHost>   server_id = AbInterfaceMobiLinkServer
I. 2011-09-03 18:52:07. <OEHost>   token = !
I. 2011-09-03 18:52:07. <OEHost>   backend connect = host=127.0.0.1;port=80;
I. 2011-09-03 18:52:07. <OEHost>   rs connect = https=1;host=192.168.70.30;port=443;trusted_certificates=C:\RelayServerOutboundEnabler\AumConRoot.crt
I. 2011-09-03 18:52:07. <OEHost>   reconnect delay = 5
I. 2011-09-03 18:52:07. <OEHost>   receive queue limit = 20
I. 2011-09-03 18:52:07. <OEHost> 
I. 2011-09-03 18:52:07. <OEMaster> OEMaster thread started..
I. 2011-09-03 18:52:07. <OEMaster> Successfully connected to backend server: 127.0.0.1:80
I. 2011-09-03 18:52:07. <OEHost> Successfully connected to the relay server. Retrieving relay servers list..
I. 2011-09-03 18:52:07. <OEHost> Mac address: 00-0c-29-b7-ae-1e!!
I. 2011-09-03 18:52:07. <OEHost> Connection established to RS..
I. 2011-09-03 18:52:07. <OEHost> attempting to packet read..
I. 2011-09-03 18:52:07. <OEHost> Headers: HTTP/1.1 404 Not Found
    Content-Length: 1635
    Content-Type: text/html
    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET
    Date: Sun, 04 Sep 2011 01:56:05 GMT
    Connection: close                                                
E. 2011-09-03 18:52:07. <OEHost> Received HTTP error response:
    HTTP/1.1 404 Not Found
    Content-Length: 1635
    Content-Type: text/html
    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET
    Date: Sun, 04 Sep 2011 01:56:05 GMT
    Connection: close                                                
I. 2011-09-03 18:52:07. <OEHost> possibly HTTP error returned, no packet seen in response..
E. 2011-09-03 18:52:07. <OEMaster> Failed to start, exiting..
I. 2011-09-03 18:52:07. <OEMaster> OEMaster thread stopped..

RSOE PARAMETERS IN SYBASE CENTRAL
-cr "https=1;host=192.168.70.30;port=443;trusted_certificates=C:\RelayServerOutboundEnabler\AumConRoot.crt"
-f AbInterfaceMobiLinkFarm
-id AbInterfaceMobiLinkServer
-v 5
-o C:\RelayServerOutboundEnabler\Logs\AbInterfaceRelayServerOutboundEnablerLog.txt

COMMAND LINE USED TO CREATE RSHOST SERVICE ON IIS SERVER
"C:\Inetpub\wwwroot\AbInterfaceRelayServer\IAS_relay_server\Server\dbsvc.exe" -y -as -s Automatic -w AbInterfaceRelayServer "C:\Inetpub\wwwroot

\AbInterfaceRelayServer\IAS_relay_server\Server\rshost.exe" -q -qc -f "C:\Inetpub\wwwroot\AbInterfaceRelayServer\IAS_relay_server\Server\rs.config" -o C:\Logfiles

\AbInterfaceRelayServerLog.txt

RSHOST LOG FILE:
I. 2011-09-03 18:55:42. iAnywhere Relay Server Version 11.0.1.2652
I. 2011-09-03 18:55:42. 
I. 2011-09-03 18:55:42. Copyright © 2011, iAnywhere Solutions, Inc.
I. 2011-09-03 18:55:42. Portions copyright © 2011, Sybase, Inc. All rights reserved.
I. 2011-09-03 18:55:42. Use of this software is governed by the Sybase License Agreement. Refer to http://www.sybase.com/softwarelicenses
I. 2011-09-03 18:55:42. 
I. 2011-09-03 18:55:42. Machine ABINTERFACEWEBS is running Windows 2003 Build 3790 Service Pack 2
I. 2011-09-03 18:55:42. Software built for X86
I. 2011-09-03 18:55:42. <rshost> Parsing config file 'C:\Inetpub\wwwroot\AbInterfaceRelayServer\IAS_relay_server\Server\rs.config'
I. 2011-09-03 18:55:42. <rshost> Starting Relay Server 'ias_relay_server_host'
I. 2011-09-03 18:55:42. <rshost> Start logging to 'C:\Logfiles\AbInterfaceRelayServerLog.txt'
I. 2011-09-03 18:55:42. <3260.rshost:master> Memory manager version: iAnywhere shm_manager v1.1
I. 2011-09-03 18:55:42. <3260.rshost:master> Relay Server shared root version: iAnywhere shm_rs_root v1.0a
I. 2011-09-03 18:55:42. <3260.rshost:master> [options]
I. 2011-09-03 18:55:42. <3260.rshost:master>   description = 
I. 2011-09-03 18:55:42. <3260.rshost:master>   shared_mem = 10M (+69M based on initial config)
I. 2011-09-03 18:55:42. <3260.rshost:master>   verbosity = 5
I. 2011-09-03 18:55:42. <3260.rshost:master>   start = no
I. 2011-09-03 18:55:42. <3260.rshost:master>   auto_stop = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   oe_timeout_minute = auto
I. 2011-09-03 18:55:42. <3260.rshost:master> [relay_server]
I. 2011-09-03 18:55:42. <3260.rshost:master>   enable = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   host = 192.168.70.30
I. 2011-09-03 18:55:42. <3260.rshost:master>   http_port = 0
I. 2011-09-03 18:55:42. <3260.rshost:master>   https_port = 443
I. 2011-09-03 18:55:42. <3260.rshost:master>   description = Relay Server PC
I. 2011-09-03 18:55:42. <3260.rshost:master> [backend_farm]
I. 2011-09-03 18:55:42. <3260.rshost:master>   enable = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   id = AbInterfaceMobiLinkFarm
I. 2011-09-03 18:55:42. <3260.rshost:master>   description = Aboriginal Interface MobiLink Farm
I. 2011-09-03 18:55:42. <3260.rshost:master>   verbosity = inherit
I. 2011-09-03 18:55:42. <3260.rshost:master>   client_security = on
I. 2011-09-03 18:55:42. <3260.rshost:master>   backend_security = on
I. 2011-09-03 18:55:42. <3260.rshost:master>   inject_standard_cookie = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   inject_rs_cookie = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   inherited verbosity = 5
I. 2011-09-03 18:55:42. <3260.rshost:master> [backend_server]
I. 2011-09-03 18:55:42. <3260.rshost:master>   enable = yes
I. 2011-09-03 18:55:42. <3260.rshost:master>   farm = AbInterfaceMobiLinkFarm
I. 2011-09-03 18:55:42. <3260.rshost:master>   id = AbInterfaceMobiLinkServer
I. 2011-09-03 18:55:42. <3260.rshost:master>   description = 
I. 2011-09-03 18:55:42. <3260.rshost:master>   mac = !
I. 2011-09-03 18:55:42. <3260.rshost:master>   token = ***************
I. 2011-09-03 18:55:42. <3260.rshost:master>   up_trip_limit = 2000M
I. 2011-09-03 18:55:42. <3260.rshost:master>   down_trip_limit = 2000M
I. 2011-09-03 18:55:42. <3260.rshost:master>   verbosity = inherit
I. 2011-09-03 18:55:42. <3260.rshost:master>   inherited verbosity = 5

RS.CONFIG FILE CONTENTS
[options]
start = no
verbosity = 5

[relay_server]
enable          = yes
host            = 192.168.70.30
http_port       = 0
https_port      = 443
description     = Relay Server PC

[backend_farm]
enable          = yes
id              = AbInterfaceMobiLinkFarm
client_security = on
backend_security= on
description     = Aboriginal Interface MobiLink Farm

[backend_server]
enable   = yes
farm     = AbInterfaceMobiLinkFarm
id       = AbInterfaceMobiLinkServer

IIS LOG FILE
-Software: Microsoft Internet Information Services 6.0
-Version: 1.0
-Date: 2011-09-04 01:26:19
-Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
2011-09-04 01:26:19 W3SVC1 192.168.70.30 POST /ias_relay_server/server/rs_server.dll - 443 - 192.168.70.25 IAS_OE_UpChannel 404 0 3
-Software: Microsoft Internet Information Services 6.0
-Version: 1.0
-Date: 2011-09-04 01:42:24
-Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
2011-09-04 01:42:24 W3SVC1 192.168.70.30 POST /ias_relay_server/server/rs_server.dll - 443 - 192.168.70.25 IAS_OE_TempChannel 404 0 3
2011-09-04 01:47:01 W3SVC1 192.168.70.30 POST /ias_relay_server/server/rs_server.dll - 443 - 192.168.70.25 IAS_OE_TempChannel 404 0 3
-Software: Microsoft Internet Information Services 6.0
-Version: 1.0
-Date: 2011-09-04 01:56:05
-Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
2011-09-04 01:56:05 W3SVC1 192.168.70.30 POST /ias_relay_server/server/rs_server.dll - 443 - 192.168.70.25 IAS_OE_TempChannel 404 0 3

asked 03 Sep '11, 22:11

Bill%20Aumen's gravatar image

Bill Aumen
2.0k294573
accept rate: 16%

edited 04 Sep '11, 12:09


Hi Bill,

How are you doing.

Your dbsvc command gave us a hint that your are not deploying the RS at the location that RSOE expects by default. Adding url_suffix=/AbInterfaceRelayServer/IAS_relay_server/Server/rs_server.dll to the -cr switch of the RSOE should fix the issue.

Due to the mismatch location, IIS is returing 404 without handing the request to RS for processing and so RS logging is not possible in this case.

Regards,

-Wing

permanent link

answered 04 Sep '11, 21:59

Wing%20Wong's gravatar image

Wing Wong
266111
accept rate: 11%

Thanks Wing. We are trying to create an additional TEST copy of the Relay Server setup you helped us get running a couple of years ago. But in following our fairly detailed documentation, looks like I had a grey hair moment. I am moving things to the proper (default) locations now.

(06 Sep '11, 11:01) Bill Aumen
Comment Text Removed

I have made some progress, if progress can be measured by moving on to a new error... :)

After moving folders to proper (default) location and going thru all web service, Relay Pool, etc config steps again to reference new folders, here is the new error message.

Does the "Unauthorized" message refer to a folder on the web server, cert error, or ???

I. 2011-09-06 14:04:58. iAnywhere Outbound Enabler Version 11.0.1.2652 I. 2011-09-06 14:04:58. I. 2011-09-06 14:04:58. <oehost> [Outbound Enabler] I. 2011-09-06 14:04:58. <oehost> verbosity = 5 I. 2011-09-06 14:04:58. <oehost> farm = AbInterfaceMobiLinkFarm I. 2011-09-06 14:04:58. <oehost> server_id = AbInterfaceMobiLinkServer I. 2011-09-06 14:04:58. <oehost> token = ! I. 2011-09-06 14:04:58. <oehost> backend connect = host=127.0.0.1;port=80; I. 2011-09-06 14:04:58. <oehost> rs connect = https=1;host=192.168.70.30;port=443;trusted_certificates=C:RelayServerOutboundEnablerAumConRoot.crt I. 2011-09-06 14:04:58. <oehost> reconnect delay = 5 I. 2011-09-06 14:04:58. <oehost> receive queue limit = 20 I. 2011-09-06 14:04:58. <oehost> I. 2011-09-06 14:04:58. <oemaster> OEMaster thread started.. I. 2011-09-06 14:04:58. <oemaster> Successfully connected to backend server: 127.0.0.1:80 I. 2011-09-06 14:04:58. <oehost> Successfully connected to the relay server. Retrieving relay servers list.. I. 2011-09-06 14:04:58. <oehost> Mac address: 00-0c-29-b7-ae-1e!! I. 2011-09-06 14:04:58. <oehost> Connection established to RS.. I. 2011-09-06 14:04:58. <oehost> attempting to packet read.. I. 2011-09-06 14:04:58. <oehost> Headers: HTTP/1.1 401 Unauthorized Content-Length: 1539 Content-Type: text/html Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET Date: Tue, 06 Sep 2011 21:07:12 GMT Connection: close

E. 2011-09-06 14:04:58. <oehost> Received HTTP error response: HTTP/1.1 401 Unauthorized Content-Length: 1539 Content-Type: text/html Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET Date: Tue, 06 Sep 2011 21:07:12 GMT Connection: close

I. 2011-09-06 14:04:58. <oehost> possibly HTTP error returned, no packet seen in response.. E. 2011-09-06 14:04:58. <oemaster> Failed to start, exiting.. I. 2011-09-06 14:04:58. <oemaster> OEMaster thread stopped..

(06 Sep '11, 17:14) Bill Aumen
Replies hidden
1

Trouble shooting 401 Unauthorized in OE is first to figure out if the error came from the RS or the Web server. This can be done by looking at the RS log. RS11 has two possible reason for issuing a 401. 1) Mac address mismatch. 2) Token mismatch. We deliberately don't send the failing reason back to the OE so that malicious attempt cannot use the info to identify valid MAC address and/or token. According to the RS configuration that you had posted previously, I believe you are not requiring any particular MAC or token and so it is unlikely that the 401 is from the RS. There can be a variety of reason a web server can response with a 401 and the sub status code record in the web server access log is the most useful tool to trace back what the issue is. Web server by default also don't sent the sub status code back to the client in the response for the same security reason.

Since you had just moved the RS extensions to a new location, instead of going through the normal trouble shooting steps, you might want to jump ahead and check if the authentication setting under ias_relay_server/server allows anonymous access. The OE requires that. According to your OE command line, you are not using client authentication and so your web server should be configure to ignore client cert for requests accessing ias_relay_server/server.

(06 Sep '11, 17:49) Wing Wong

Working now.

After a number of changes in IIS Administrator, I could not get it going. So I un-installed IIS, re-installed IIS, and re-created the web site, and now it works.

Looks like I had something wrong in my original setup and was never able to correct it by re-tracing my steps and settings.

Thanks again Wing for pointing me to the right spot.

permanent link

answered 07 Sep '11, 18:22

Bill%20Aumen's gravatar image

Bill Aumen
2.0k294573
accept rate: 16%

Hello Bill,

Does RS work fine since that time? We are monitoring our Relay Server, and I am just interested in other RS installations. How they live :)

Kind regards,

Vlad

(12 Jul '12, 07:44) Vlad

Hi Vlad,

Yes, working very well. We now have 6 running.

We get an occasional hangup, always traceable to other proxy servers, load balancers, etc. in the infrastructure going off-line, so we have a Scheduled Task that re-starts the services each morning "just in case". That has kept everything humming along smoothly.

(12 Jul '12, 11:35) Bill Aumen
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×11

question asked: 03 Sep '11, 22:11

question was seen: 3,060 times

last updated: 12 Jul '12, 11:35