We want to use SNMP to monitor some values in a ASA 10.0.1.4239 64bit instance on Windows 2008R2 64bit.

I have created a sasnmp.ini withe this content.

[SAAgent]
TrapPollTime=5

[DB1]
ConnStr=ENG=xx;DBN=yy;UID=SNMPExtensionAgent;PWD=password;links=SHMEM
CacheTime=0
DBSpaceCacheTime=600
Disabled=0

I have tested that I can connect to the Database with the Connectionstring define above.

As mentioned in the Docs I have restarted the SNMP service. The ProcessExplorer shows me that 2 snmp.exe are loaded. One is 64bit and one 32bit.

When I request the OIDs mentioned in the docs I get nothing. How can I proof that the Extension Agent is loaded ?

Is it possible in the 64bit environment ? Do I miss something ?

asked 03 Aug '11, 09:06

Thomas%20Duemesnil's gravatar image

Thomas Dueme...
2.5k233560
accept rate: 15%

edited 05 Aug '11, 06:02


Here are the registry entries that need to exist in order for the SNMP agent to load the SA extension agent. Note that this must be in the 32-bit registry, so use regedt32.exe rather than regedit.exe. These instructions assume you're using SA version 12.0, but just change "12" to "11" or "10" for other versions.

Under HKLM:SYSTEM/CurrentControlSet/Services/SNMP/Parameters/ExtensionAgents, you need a string value called "SA" containing the string "SOFTWARE/Sybase/SQL Anywhere 12.0/SNMPDLL".

That string points to another registry entry: HKLM:SOFTWARE/Sybase/SQL Anywhere 12.0/SNMPDLL. Under that key, you need two string values. "Pathname" is the fully-qualified filename of the dbsnmp12.dll, and "IniFile" is the fully qualified filename of the sasnmp.ini file.

Once those registry entries are in place, stop and restart the SNMP service and you should be OK. Use an SNMP application to get the value for OID .1.3.6.1.4.1.897.2.3.1 - if everything is properly configured, you should get a value indicating the version of the SA extension agent, for example "12.0.1.3406".

permanent link

answered 05 Aug '11, 09:05

Graeme%20Perrow's gravatar image

Graeme Perrow
8.5k371109
accept rate: 52%

The 10.0.1 x64 database server does not have support for SNMP (only 32-bit). See the description from the 11.0.1 docs regarding OS support: http://dcx.sybase.com/index.html#1101/en/dbadmin_en11/da-snmpconfig-secta-3267234.html

You'll note that 'dbsnmp10.dll' (a required DLL for the database server to use SNMP functions) is only provided in the win32 folder, not x64.

permanent link

answered 03 Aug '11, 16:45

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

I found the same comment in the v12.0.1 documentation. Is it true that it is not possible in v12 too?

As the SNMP Service on windows 64 are two instances of snmp.exe one 64bit and one 32bit I thought it would be possible to use the 32 bit Extension Agent in 64bit windows without a problem.

(04 Aug '11, 02:17) Thomas Dueme...
Replies hidden

I have never tried this on a 64-bit machine. I know the 64-bit agent won't load the 32-bit extension agent (dbsnmpXX.dll), but I didn't know there was a 32-bit agent also available. I'll have a look and let you know.

(04 Aug '11, 06:42) Graeme Perrow

FYI as long as the right (32-bit) registry entries are made, the 32-bit SNMP extension agent on a 64-bit machine does work. As far as I can tell, the 64-bit installer does set up the proper registry entries, so it should just work. When I get to work, I'll post the registry entries so you can check them and/or create them.

(05 Aug '11, 06:37) Graeme Perrow
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×113
×107
×36
×1

question asked: 03 Aug '11, 09:06

question was seen: 1,732 times

last updated: 05 Aug '11, 09:05