when I launch dbisql (SQLA V10.0.1.3706), if I type any key I have the message "Error! There is not enough memory to add the text" as I have enough memory on my computer.

But if I launch Sybase Central, connect to the data base, then launch dbisql with "Open interactive SQL" by right click on the data base name, then functioning is correct.

Do you have any idea on that error message ?

Denelbe

asked 20 Jun '11, 10:15

Denelbe's gravatar image

Denelbe
21113
accept rate: 0%


When you get that message, it means that DBISQL has exhausted its memory heap. DBISQL 10.0.1 has a fixed maximum heap size, which is around 64M. Sybase Central 5.0.0 has a higher limit (200M), which is why launching DBISQL from Sybase Central can fix the problem.

You can run DBISQL with a 200M heap by "-Xmx200M" on the DBISQL command line.

You can also configure DBISQL to always use up to 200M by creating a registry key called

HKLM\SOFTWARE\Sybase\SQL Anywhere\10.0\DBISQL\VMArgs

In that key, add a string value called "-Xmx200M". It doesn't matter what data value you give it. Now, whenever you run DBISQL, it will use up to a 200M heap.

Note that if you are running DBISQL 10.0.1 on a 64-bit machine, the registry key entry location is slightly different:

HKLM\SOFTWARE\Wow6432Node\Sybase\SQL Anywhere\10.0\DBISQL\VMArgs

-- Chris Irie [Sybase]

permanent link

answered 20 Jun '11, 15:18

Chris%20Irie's gravatar image

Chris Irie
8051314
accept rate: 46%

Where can I put that parameter if I'm running DBISQL on a Linux 64bits machine??

I found once a script to do it, but I can't find it anymore.

Could you help me?

permanent link

answered 08 Nov '12, 13:50

Japegamx's gravatar image

Japegamx
11
accept rate: 0%

Ok. I found it!!

For anyone who have the same problem, here is how it can be fixed.

Run "dbisql" command with the "-batch" parameter. This will create a script that executes dbisql, but you can modify the "-Xmx" para meter inside.

Edit the "dbisql.sh" generated and change the value of -Xmx parameter of the JVM to "200m" and that's it.

See ya!

permanent link

answered 08 Nov '12, 14:43

Japegamx's gravatar image

Japegamx
11
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×76
×37

question asked: 20 Jun '11, 10:15

question was seen: 5,110 times

last updated: 08 Nov '12, 14:44