Hi, I have by mistake set the isql_log option permanently to a false file (set option isql_log=false_file.log). What is the way for rollbacking this option so that it will take its default value.

Thanks

asked 22 Mar, 04:58

Sarkis's gravatar image

Sarkis
1802318
accept rate: 0%


This is an IQ option, not available in SQL Anywhere.

Currently, you may have a file "false_file.log" somewhere that is gathering up all your SQL statements.

To turn that off, try setting it to the empty string...

SET OPTION PUBLIC.ISQL_LOG = '';

permanent link

answered 22 Mar, 08:30

Breck%20Carter's gravatar image

Breck Carter
25.6k427586844
accept rate: 20%

doesn't this last statment (SET OPTION PUBLIC.ISQL_LOG = '';) means that no any transaction log is anymore used? What I want is to have the default option (having .log file with the same name as the database file and in the same path)

(22 Mar, 10:42) Sarkis
Replies hidden
2

Please follow the link and read the Help page about isql_log. This option has absolutely nothing to do with the transaction log.

(22 Mar, 10:55) Breck Carter

Thanks, I have mixed them.

(22 Mar, 11:56) Sarkis
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×76
×21

question asked: 22 Mar, 04:58

question was seen: 424 times

last updated: 22 Mar, 11:56