The forum will be down for scheduled maintenance on Saturday, March 4 beginning at 10am EST. Actual downtime is unknown but may be several hours.

I'd like to add a comment on DCX, which I have not done for a while.

Previously, I could use my MySybase credentials to do so. That does not seem to work anymore.

When I'm using my SCN credentials, I'm told by the "SAP ID Service" they are accepted:

"You have now been authenticated. Your request has been forwarded to the target system for processing."

That looks fine to me but when redirected to DCX, I still are not logged in - or at least I still cannot add a comment, and the "Login" button is still shown, and when using it a second time, the SAP ID Service does not ask for credentials but tells me the same message again...

What do I have to do now?

asked 01 May '15, 07:06

Volker%20Barth's gravatar image

Volker Barth
29.5k291441646
accept rate: 32%

edited 01 May '15, 07:09


OK, after Mark has noted that the DCX URL should be http://dcx.sap.com, not http://dcx.sybase.com, I guess the mystery has cleared up:

I had used the sybase URL to login in (just because I had stored this link) and was re-directed to the same site but apparently was logged in at the SAP site - and I still am (and so I am able to comment there). That behaviour is astonishing at least:)

I'm gonna update my DCX links - however, if the Sybase-hosted DCX should not be used anymore, please tell us so...


Just more on this issue:

  • If I use the DCX links from the v12.0.1 and v16 documentation menues, I'm directed to the SAP-hosted DCX (I guess that was a behaviour change introduced in a newer EBF).
  • However, if I use the local help and then follow its DCX link on the page footer, it still links to a page on the Sybase-hosted DCX. - And frankly, that's what I mostly use (often in order to copy those links as part of my contributions here).

So the DCX URL situation seems somewhat unclear to me...

permanent link

answered 05 May '15, 03:08

Volker%20Barth's gravatar image

Volker Barth
29.5k291441646
accept rate: 32%

edited 05 May '15, 03:51

Just as a suggestion:

Given the fact that currently both DCX-sites are available and that the Sybase-hosted DCX may be necessary for the links from the local help (in case a redirection is not possible), it would be nice if a login attempt at the Sybase-hosted DCX would be directed to the SAP-hosted site. (So I would not have noticed that there are indeed two different sites...)

(06 May '15, 03:59) Volker Barth

Hi Volker,

As far as the DCX server is concerned, you were logged in at 2015-05-01 06:57:30.745000 east time. However for the DCX client to be aware of that, a cookie needs to be set. I am suspecting your machine does not allow setting cookies. Could you please check? Also, are you able to login on a different machine or using a different browser?

Kind regards, Shengyu

permanent link

answered 01 May '15, 11:02

sbao's gravatar image

sbao
26
accept rate: 0%

reverted 01 May '15, 11:28

I find I have a similar problem with IE10 myself. I have found that going to FireFox/Mozilla will work for me on the same machine. Chrome may work too ... but I haven't tested that today.

In fact this is the second posting today that I had to do that for ...

(01 May '15, 11:18) Nick Elson S...

I don't think I have disabled cookies within Firefox. I'm going to try on a different machine after the weekend...

(02 May '15, 06:26) Volker Barth
Replies hidden

I have tried on a different machine both with FF and IE (and had certainly not disabled cookies). Nevertheless the behaviour remains the same: I get the cited response from the SAP ID Service, but do not get logged in in DCX.

Any further hints are appreciated...

(04 May '15, 06:01) Volker Barth

I noticed the same behavior. Cookies are explicitly allowed for dcx.sybase.com, so that's not the reason.

(04 May '15, 07:43) Reimer Pods
Replies hidden

Which makes the "X" in "DocCommentXchange" somewhat difficult:)

(04 May '15, 08:22) Volker Barth

Can you add http://*.sap.com and https://*.sap.com to your trusted site and try again in IE?

(04 May '15, 10:00) sbao

Well, I certainly do not like to have to add sites to those (especially for those not using https...) - but even if I do, the behaviour seems to remain unchanged, so I'm stuck with that.

(04 May '15, 10:40) Volker Barth
1

Reimer: Note that DCX is hosted by sap.com now, not sybase.com! So allowing dcx.sybase.com will not be relevant.

(04 May '15, 13:15) Mark Culp

Well, I guess Reimer sees the same URL as me:

http://dcx.sybase.com/index.html#sa160/en/sqlanywhere_en16/help_top_index.htm

and

http://dcx.sybase.com/index.html#1201/en/sqlanywhere_en12/help_top_index.htm

So are we using an existing but old link?


FWIW, it shows the same current comments as the dcx.sap.com site, so are these URLs just mirrored?

(04 May '15, 15:41) Volker Barth

Using dcx.sap.com instead of dcx.sybase.com fixed ist. Thanks, Volker, for pointing out the difference.

(05 May '15, 09:09) Reimer Pods
showing 4 of 10 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15
×2

question asked: 01 May '15, 07:06

question was seen: 697 times

last updated: 06 May '15, 03:59