The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

On Windows Mobile using Ultralite 12.0.1.4183 in .Net CF 3.5 I'm trying to synch using https with a trusted certificate.

First I tried without the trusted certificate I got the 24 error code. Then I tried using the browser to mark it as trusted as indicated in the docmentation for trusted_certificate in the 2nd bullet point. I still got the 24. I then tried using trusted_certificate as below but got the "The option 'trusted_certificate' is not recognized" error message.

host={0};port={1};timeout=60;trusted_certificate=rsaroot.crt;

I'm not sure what else I need to do.

asked 14 Apr '15, 16:03

JonathanChapman01's gravatar image

JonathanChap...
36112
accept rate: 0%

edited 14 Apr '15, 16:05


Looks like a documentation bug.

There's an 's' on the parameter name: trusted_certificates.

permanent link

answered 14 Apr '15, 16:18

Tim%20McClements's gravatar image

Tim McClements
1.6k1623
accept rate: 34%

1

Beat me by nine seconds.

(14 Apr '15, 16:22) Reg Domaratzki

As a follow-up I've never had to add the certificates before so can you confirm what is in the file. I tried using the certificate from the server which it seemed to like but this caused me to still get the 24 error.

(14 Apr '15, 16:36) JonathanChap...
Replies hidden
1

The certificate should be the (public) root certificate of the top-level certificate authority.

See: http://sqlanywhere-forum.sap.com/questions/19138/what-impact-will-the-switch-to-openssl-have-on-sql-anywhere-strong-encryption

for more details. Also see KBA 2134354 - Error: "TLS handshake failure" or "Server certificate not trusted" after upgrading to a higher support package of SQL Anywhere 12 or SQL Anywhere 16.

The trusted certificate is expected to be in PKCS #8, PEM format:

-----BEGIN CERTIFICATE----- ... -----END CERTIFICATE-----

(15 Apr '15, 10:10) Jeff Albion

The option name should be trusted_certificates, and not trusted_certificate.

permanent link

answered 14 Apr '15, 16:18

Reg%20Domaratzki's gravatar image

Reg Domaratzki
4.8k33269
accept rate: 41%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×266
×128

question asked: 14 Apr '15, 16:03

question was seen: 384 times

last updated: 15 Apr '15, 10:10