Good morning,

I am running SQL Anywhere 16 with MobiLink 16.0.0.2014 and I run into the following problem:

One of my tables is breaking the sync, when I try to send an update from the client to the consolidated database:

E. 2014-11-23 15:26:00. <1> [-10233] Table 'ZODB_CUSTOMERS_PARTNERS' does not have a column named 'TIMESTAMP'
E. 2014-11-23 15:26:00. <1> [-10058] Unable to open upload_update

When I check Sybase Central/MobiLink and switch to the Events tab, I see the following for the upload_update:

​ZODB_CUSTOMERS_PARTNERS (DBA): upload_update​
/* Update the row in the consolidated database. */

UPDATE "DBA"."ZODB_CUSTOMERS_PARTNERS"
SET "UPDKZ" = {ml r."UPDKZ"},
    "LASTNAME" = {ml r."LASTNAME"},
    "FIRSTNAME" = {ml r."FIRSTNAME"},
    "FUNCTION" = {ml r."FUNCTION"},
    "EMAIL" = {ml r."EMAIL"},
    "PHONE" = {ml r."PHONE"},
    "MOBILE" = {ml r."MOBILE"}
WHERE "SMSUSER" = {ml r."SMSUSER"}
    AND "EKUNNR" = {ml r."EKUNNR"}
    AND "EKUNPNR" = {ml r."EKUNPNR"}

However, when I look at the mlsrv.log, I see the following statement (difference in bold):

I. 2014-11-23 15:26:00. <1> upload_update ZODB_CUSTOMERS_PARTNERS

                /* Update the row in the consolidated database. */

                UPDATE "DBA"."ZODB_CUSTOMERS_PARTNERS"
                SET "UPDKZ" = {ml r."UPDKZ"},
                    "LASTNAME" = {ml r."LASTNAME"},
                    "FIRSTNAME" = {ml r."FIRSTNAME"},
                    "FUNCTION" = {ml r."FUNCTION"},
                    "EMAIL" = {ml r."EMAIL"},
                    "PHONE" = {ml r."PHONE"},
                    "MOBILE" = {ml r."MOBILE"}
                WHERE "SMSUSER" = {ml r."SMSUSER"}
                    AND "EKUNNR" = {ml r."EKUNNR"}
                    AND "EKUNPNR" = {ml r."EKUNPNR"}
                    AND {ml r."TIMESTAMP"} > "TIMESTAMP"

I do not have the TIMESTAMP column on the remote, only on the consolidated. Therefore {ml r."TIMESTAMP"} is leading to an error.

Is this working as designed? Or did I do something wrong?

Thanks for your help, Alex

asked 24 Nov '14, 02:27

Alexander%20Ilg's gravatar image

Alexander Ilg
13181016
accept rate: 0%


Have you perhaps updated the upload script in the consolidated, while the MobiLink server is still running? By default in version 16, MobiLink will not check for updated scripts after it starts - you must enable that process by using the mlsrv16 -zf switch (recommended for development, not for production).

Otherwise, restarting the MobiLink server should pick up any deployed script changes while the MobiLink server was previously running.

permanent link

answered 24 Nov '14, 14:45

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

The Events tab in Sybase Central is showing the SQL that the model would create (when the model is deployed), not what is currently in the consolidated database. Perhaps the synchronization model has not been deployed to the consolidated database, or needs to be re-deployed? http://dcx.sybase.com/index.html#sa160/en/mlstart/mg-about-s-5363174.html

permanent link

answered 24 Nov '14, 10:02

Graham%20Hurst's gravatar image

Graham Hurst
2.6k11843
accept rate: 28%

Thank you Graham - the SQL displayed in Sybase Central is what is deployed to the consolidated. I am currently the only one the system.

(24 Nov '14, 10:21) Alexander Ilg
Replies hidden

What is the contents of the according script in the ml_script table? That should tell the real situation...

(24 Nov '14, 11:54) Volker Barth
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×278

question asked: 24 Nov '14, 02:27

question was seen: 286 times

last updated: 24 Nov '14, 14:45