The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

a) If I run the SQL Anywhere Network Server Version 12.0.1.3967 with -gn option, then MaxMultiprogrammingLevel > 100:

a1) -cs -cl 3G -gns -gna 1 -gn 100 ==>

Minimum cache size: 3145728K, maximum cache size: 3149704K
Multiprogramming level: minimum:4, current:100, maximum:400

a2) -cs -cl 3G -gns -gna 1 -gn 70 ==>

Minimum cache size: 3145728K, maximum cache size: 3272584K
Multiprogramming level: minimum:4, current:70, maximum:280

a3) -cs -cl 3G -gns -gna 1 -gn 80 ==>

Minimum cache size: 3145728K, maximum cache size: 3231624K
Multiprogramming level: minimum:4, current:80, maximum:320

b) But if I run the SQL Anywhere Network Server Version 12.0.1.3967 with -gnl option, then MaxMultiprogrammingLevel = 80:

b1.1) -cs -cl 3G -gns -gna 1 -gnl 100 ==>

Minimum cache size: 3145728K, maximum cache size: 3477384K
Multiprogramming level: minimum:100, current:80, maximum:80

b1.2) -cs -cl 2G -gns -gna 1 -gnl 100 ==>

Minimum cache size: 2097152K, maximum cache size: 3477384K
Multiprogramming level: minimum:100, current:80, maximum:80

b2.1) -cs -cl 3G -gns -gna 1 -gnl 70 ==>

Minimum cache size: 3145728K, maximum cache size: 3477384K
Multiprogramming level: minimum:70, current:75, maximum:80

b2.2) -cs -cl 2G -gns -gna 1 -gnl 70 ==>

Minimum cache size: 2097152K, maximum cache size: 3477384K
Multiprogramming level: minimum:70, current:75, maximum:80

Is this correct behavior -gnl option?

asked 13 Nov '14, 03:00

Ilia63's gravatar image

Ilia63
706252947
accept rate: 16%

edited 13 Nov '14, 03:12


In my understanding, this is documented behaviour when you do not specify the -gnh option. Then the maximum multiprogramming level has the following

Default
Four times the -gn database server option value

  • In case you set the -gn option, the maximum value is four times that value, as your test series (a) shows.
  • In case you set the -gnl option but not the -gn option, the latter has its default (20), so the maximum value is still four times that default, aka 80, as the other tests reveal.
permanent link

answered 13 Nov '14, 04:08

Volker%20Barth's gravatar image

Volker Barth
29.3k287438644
accept rate: 32%

edited 13 Nov '14, 04:09

Thanks!...

(13 Nov '14, 04:26) Ilia63
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×404

question asked: 13 Nov '14, 03:00

question was seen: 392 times

last updated: 13 Nov '14, 04:26