I've been asked to install an ancient version of SQLAnyhere - ASA 8 - to bring an old DB back to life.

I had to install on an old version of Ubuntu (8.04) and it mostly seems to have worked.

However, some of the tools don't.

In particular, dbisql complains "The Java2 runtime environment could be found but not loaded. The application could not be started."

I believe that the ASA8 install installed some old version of Java, but that obviously wasn't quite enough. I even tried a manual install of Java6 - and that made no difference.

Any suggestions on how to get this old bird off the ground?

asked 06 Nov '14, 04:09

alexlake's gravatar image

alexlake
16113
accept rate: 0%


I'd try the C-based DBISQLC, it does not require Java and should be enough to apply SQL scripts and ad-hoc queries. (I still use it with v12.0.1...)

permanent link

answered 06 Nov '14, 05:13

Volker%20Barth's gravatar image

Volker Barth
30.0k294447654
accept rate: 32%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×64
×41
×31

question asked: 06 Nov '14, 04:09

question was seen: 401 times

last updated: 06 Nov '14, 11:43