The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

Our product use SA silent installation on Windows 64/32 bit. In both cases after installation we use exe's from bin32 directory. For SA12 using installation property SA32=1 on Windows 64 bit machines was installed in directory bin32 all required exe's (dblic, dbsrv ...) but for SA16 using the same property in bin32 not all exe's installed only some exe's and it is not enough to use SA32 server on 64-bit machnes. We doesn't find any changes in SA16 documentation in compare with SA12 documentation - the same mechanism and properties are described. In the same time if use regular(manual) SA16 installion on 64 bit machine and choose SA32 (SA 32 bit server) include as result in directory bin32 exist the same exe's set as in bin64. What is changed in SA16 since SA12 silent installation mechanism!?

Thanks in advance for answers, Hanan Brener

asked 23 Apr '14, 12:42

HBrener's gravatar image

HBrener
426212333
accept rate: 0%


Hi Hanan,

In SQL Anywhere 16 you can use SERVER32, SERVER64, CLIENT32, and CLIENT64 to select these options. The existing documentation will be updated to reflect this. See CR#732338 for further details.

permanent link

answered 23 Apr '14, 13:38

Mikel%20Rychliski's gravatar image

Mikel Rychliski
2.1k1641
accept rate: 30%

Also the 16.0 doc page for silent installs has a comment about the documentation error.

Silent installs using the SQL Anywhere installer

(24 Apr '14, 14:10) JBSchueler
Replies hidden

@Jack: I've corrected the link:)

(25 Apr '14, 00:32) Volker Barth

Thanks it works, but need take in consideration that on GA version it not work, work only since build 1447. With previous SA versions (9,10,12) was requirement use GA after maintenance EBF to move to version XX.0.1 and than last EBF. In SA16 as I understand we can use last EBF as GA install!?!

(01 May '14, 06:50) HBrener
Replies hidden

This is correct, there is no '16.0.1' release. You can upgrade directly from GA to any EBF.

(01 May '14, 10:01) Mikel Rychliski
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×186

question asked: 23 Apr '14, 12:42

question was seen: 7,329 times

last updated: 01 May '14, 10:01