The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

We have users reporting an error message (Error: -100) when trying to connect with our databases (12.0.1.3994). Yesterday the MS updates have been automatically applied in the server and the branches also reported internal network issues with their communication service provider.

After a few exploratory steps, we noticed that the SASRV.INI had today’s date/time stamp and all the server connections have been wiped out from the file. The issue was solved after we found a workstation that connected fine with our application via SQLANY12 where the SASRV.INI had not been changed. However, from ISQL the "Find" feature does not list any of the available network services even after fixing the INI file.

Is there  a way to avoid the SASRV.INI to be wiped out?  
If we set the file to READ-ONLY, would it prevent the issue to happen in the future? 
Are there any side-effects on doing so?
This question is marked "community wiki".

asked 15 Jan '14, 13:51

Derli%20Marcochi's gravatar image

Derli Marcochi
1.6k323877
accept rate: 33%


While I have no idea why the file would have been emptied, the sasrv.ini file is a cache of addresses, used to speed up the search for previously used servers. It is solely for convenience and should not be relied upon. It is not intended to be edited by users.

Bottom line: If you can't connect once the sasrv.ini file has been removed or truncated, then your connection string does not contain enough information.

permanent link

answered 15 Jan '14, 14:32

Graeme%20Perrow's gravatar image

Graeme Perrow
8.3k369106
accept rate: 52%

1

Well, this specific customer has users in different sub-nets and only the ones in the main office were able to connect without the the SASRV.INI file. The INI file has been in place in the remote branches for years but was somehow emptied in some workstations. Suggestions?

(15 Jan '14, 14:41) Derli Marcochi
Replies hidden
2

If the server had gone down at some point, and then the clients tried to connect and failed, the address would have been removed from the cache. Then when the server came back up, they wouldn't have been able to connect. This is why relying on the .ini file is a bad idea. The connection string / DSN must contain enough information to find the server.

(15 Jan '14, 14:43) Graeme Perrow
1

Since the branches are in different sub-nets I am not sure if the sasrv.ini file couldn't be avoided without a broadcast repeater. Will try.

(15 Jan '14, 15:54) Derli Marcochi
2

You might want to add the HOST=<IP or Hostname> connection parameter (and possibly DOBROAD=NONE). IIRC this works over subnet boundaries.

(16 Jan '14, 03:32) Reimer Pods
Replies hidden
2

Reimer's comment is correct, although using "DoBroad=None" can only be done with the LINKS parameter, not HOST. However it is implied (and therefore not necessary) with HOST anyway.

(16 Jan '14, 06:45) Graeme Perrow
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×46
×9

question asked: 15 Jan '14, 13:51

question was seen: 1,423 times

last updated: 16 Jan '14, 06:45