I have few computers on one network all xp connected to server 2003 and now i got one work station with windows 7 pro, the XP WS works fine but the win7 pro can't connect to db on Server i did turn off the firewall... can anybody help?

asked 04 Dec '13, 16:14

Juzek's gravatar image

Juzek
30112
accept rate: 0%

We have similar mixtures with no problems, so your new Win7 will definitely work.

Exactly what error message are you getting?

What happens if you modify the ODBC entry on the Win7 workstation to specify the fixed ip address? This will eliminate the need for the client to search for the server. (ODBC, Network tab, box to the right of tcpip checkbox: enter "ip=192.168.x.x")

Is your new machine 64 bit (and the old working machines all 32 bit)? Does the client side install correctly install the 64 bit driver and the ODBC entry?

(04 Dec '13, 23:19) Bill Aumen

there are no errors,the program installed on win7 can't connect to DB on server, the machine is 32bit the program i'm using on it can't run on 64bit, i didn't try to eliminate the need for search. thx, i'll try.

(06 Dec '13, 16:38) Juzek

We have hit similar situation with windows 2008 as a client (but the core is similar to Win7), where no connection could be established, same for dblocate. Turning the firewall off didnt help either. Desperate situation was asking for desperate action, so a colleague of mine has added an exception into the built-in (disabled) firewall (both TCP and UDP) for the specific port where the dbsrv12 was running on, and voila, magic happened. Give is a shot, also if you're running some extra protection on your win7, like antivirus, try to disable it for a while, most of the products on the market are bundled with additional protection modules to check and control network traffic as well..

permanent link

answered 05 Dec '13, 03:06

marchello's gravatar image

marchello
3702614
accept rate: 14%

edited 05 Dec '13, 03:07

thx! i'll try this.

(06 Dec '13, 16:38) Juzek

Windows 7 seems to block UDP broadcasts used by the server engine to advertise it's service. Applying the HOST parameter in the Network tab's IP-Parameter might help (HOST=MyDbServer;DOBROAD=NONE).

permanent link

answered 05 Dec '13, 08:55

Reimer%20Pods's gravatar image

Reimer Pods
4.2k334583
accept rate: 11%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15

question asked: 04 Dec '13, 16:14

question was seen: 800 times

last updated: 06 Dec '13, 16:38