The forum will experience an outage sometime between February 10 at 7:00pm EST and February 12 at 11:59 EST for installation of security updates. The actual time and duration of the outage are unknown but attempts will be made to minimize the downtime. We apologize for any inconvenience.

Hi, I have installed SQL Anywhere 16(sa16developerlinux) in my linux 32-bit machine - Red Hat Enterprise Linux Server release 5 (Tikanga)

I compiled sqlanywhere16/sdk/dbcapi/examples/connecting.c and getting the error message - "Failed to initialize the interface! Supported version = 2".

My make file content is:

CC=gcc CFLAGS=-I. DEPS = sacapidll.h OBJ = connecting.o sacapidll.o LIBS=-ldl

%.o: %.c $(DEPS) $(CC) -c -o $@ $< $(CFLAGS)

connecting: $(OBJ) gcc -o $@ $^ $(CFLAGS) $(LIBS)

Corresponding line in connecting.c causing this error is - if( !api.sqlany_init( "MyAPP", SQLANY_API_VERSION_1, &max_api_ver )). I tried with SQLANY_API_VERSION_2 also, but still getting same error.

Does anyone know how to correct this problem?

Thanks

asked 21 Nov '13, 19:55

Vaish's gravatar image

Vaish
90449
accept rate: 0%


Hi All, Plz ignore my question, I got this issue resolved. Rootcause - SQLANY16 environment variable was not set.

Thanks

permanent link

answered 21 Nov '13, 22:13

Vaish's gravatar image

Vaish
90449
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×187
×60
×34

question asked: 21 Nov '13, 19:55

question was seen: 571 times

last updated: 21 Nov '13, 22:13