This seems to be a problem which has developed only recently. Using SQL Anywhere version 11 build 2308 32 bit, on two separate customer sites (one using Windows 7 computers and one using XPs), I have had to add a HOST=xxx.xxx.xxx.xxx statement in the ODBC configuration to get the client computer to connect to the server. Then everything functions fine. These are simple two or three computer peer-to-peer networks. dblocate on the client can't find any servers but I can ping the server's IP address and connect with the HOST parameter.

Windows Firewalls are on, and I have put entries to allow dbsrv11.exe both inbound and outbound.

Any help would be appreciated. Thanks.

asked 20 Nov '13, 11:10

bill_skelton's gravatar image

bill_skelton
16123
accept rate: 0%

It sounds like you've added the HOST parameter and everything is working. If dblocate cannot find the servers, then the HOST parameter is likely required. You seem to have solved the problem yourself. Can you confirm what problem you are still having?

(20 Nov '13, 11:23) Graeme Perrow

Thanks all for the replies. That gives me something to look at. We want to avoid the HOST= parameter if at all possible as it requires our installations and updates to be user specific and a "generic" installation CD won't work.

(20 Nov '13, 16:37) bill_skelton

The server discovery mechanism relies on UDP packets being propagated between servers and clients - if your firewall rules or network configuration do not permit broadcast UDP messages, the dblocate mechanism will fail to find any servers. Check to see if you can transmit UDP packets between the database clients and hosts.

If you can't, you may be required to set up the Broadcast Repeater Utility (dbns11) across the networks in order to propagate server names. Otherwise, specifying the direct "HOST=" address would also resolve the issue.

permanent link

answered 20 Nov '13, 11:25

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

We've had that issue with a lot of client's PCs, solved it the way you did. It's possibly Win7 blocking UDP broadcasts used by the server engine to advertise it's service. We didn't bother delving into network and firewall details because applying HOST parameter did the trick easily.

permanent link

answered 20 Nov '13, 11:27

Reimer%20Pods's gravatar image

Reimer Pods
4.1k334480
accept rate: 12%

i've also found that if the db engine is on a different subnet, the host parameter is required

permanent link

answered 21 Nov '13, 09:16

Tom%20Mangano's gravatar image

Tom Mangano
587182334
accept rate: 6%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×124
×14

question asked: 20 Nov '13, 11:10

question was seen: 792 times

last updated: 21 Nov '13, 09:16