Does anyone have experience of this assertion and what might be causing it?

It happens fairly regularly with a particular database, but only during a backup.

The database passes both express and full validation. We have also tried restoring a backup that pre-dates the first occurrence (then applying subsequent logs).

The only reference to it I can find is in the old NTTP newsgroups, where it was suggested that it might be connected to a VMWare bug - but in this case no virtualization is involved.

We are doing a full unload / reload just in case it really is a database corruption - but given that restoring the backup didn't fix it, the validation passes and the other case - it seems increasing unlikely that that is the answer. This will take a while to schedule as the database is about 80GB and is used 24x7.

asked 07 Oct '13, 06:44

Justin%20Willey's gravatar image

Justin Willey
6.6k106136205
accept rate: 21%

edited 07 Oct '13, 06:45

1

Only two google hits https://www.google.com/#q=%22invalid+access+to+a+null+image%22

...one unavailable right now (probably the one you found), the other on a Cisco forum says "corrupt database". As such, it's pretty rare, so you probably won't find anyone with experience on this forum. Try calling tech support because they have a vast internal problem report database.

(07 Oct '13, 07:51) Breck Carter

"Invalid Access to a NULL image" means that we failed to allocate a cache page when auto-growing the cache - the memory page received back was NULL when checking it, and we assert.

We have seen this from a few customers and yes, most of those have been associated with virtualized environments. I don't think we've yet had a reproducible in-house of the behaviour to diagnose the memory conditions precisely.

Most of our customers were able to remotely work-around the issue by strictly setting the "-ch" parameter on the server-start up switch to an explicit value - does that also work around the behaviour for yourself?

permanent link

answered 07 Oct '13, 10:24

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

Thanks Jeff - that is really useful. I will try that. This is a dedicated server so we could try a fixed cache - would that address the same issue?

(07 Oct '13, 10:40) Justin Willey
Replies hidden
2

To the best of our understanding, yes, turning off auto-sizing of the cache and fixing the cache size should also work here. Let us know if that works for you.

(07 Oct '13, 10:58) Jeff Albion

Thanks again - I'll let you know how we get on.

(07 Oct '13, 12:22) Justin Willey
2

Fixing the cache size seems to have done the trick - no assertions since then. - Many thanks.

(for anyone else coming across this - we used -c to set the initial cache size and -ca 0 to prevent re-sizing)

(11 Oct '13, 12:57) Justin Willey
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×31
×9

question asked: 07 Oct '13, 06:44

question was seen: 2,976 times

last updated: 11 Oct '13, 12:59