My question is very similar to a previous Q but I did not fully understand the answer. I am using PointSync Pro 2.1. I am seeking to have two instances of the PointSync Pro server running on the same physical machine. Each would have its own Sync(2439/2440) and Mgr(2638/2639) Port and each would be accessing its own Sybase database. I am indeed able to install two Servers (done not from a command line but from Selecting Add from the Server Manager launched from the icon tray - there is a little icon of a man with a hard hat in the icon tray. I note that the Server Manager has a Stop All option which suggests more that 1 server is allowed), each requiring its own licence key. I am able to run either server on its own. However with either server running, I am unable to start the second server. The error I receive is : <main> [-10282] Unable to create a shared memory file The fact that I can start either server on its own suggests that my installation of each is OK, to my mind anyway. I can't work out what Windows (I am trying this both on Win Server 2008 and Vista with the same result in each case) tweak I need to make to have this work. I have installed them both as StandAlone (ie not mirrored) servers. I have selected the default User Account under which to run the Service.

Any insight will be gratefully received.

asked 23 Sep '13, 06:07

AmoAmas%20AmatitAgain's gravatar image

AmoAmas Amat...
31114
accept rate: 0%

edited 23 Sep '13, 06:52

Comment Text Removed

That error almost always means you're trying to start two MobiLink servers on the same machine with the same server name. To run two servers on the same machine, you must set the server name with the -zs switch.

permanent link

answered 23 Sep '13, 11:19

Bill%20Somers's gravatar image

Bill Somers
1.1k818
accept rate: 36%

Bill, Thanks for your input on this one. The Wizard that allows you to add a new server ensures that the name you give is unique. However I tried your suggestion and still no joy. The bahaviour is slightly different in that the attempt to start the server fails immediately rather than failing after 20 secs or so of trying.

(23 Sep '13, 13:54) AmoAmas Amat...
Replies hidden

Are both MobiLink Servers trying to listen on the same TCP/IP port? What error are you getting now in the MobiLink Log?

(23 Sep '13, 17:05) Reg Domaratzki

Can you post the command lines the severs are starting with? If your wizard doesn't make that easy, you can get the command lines from Task Manager.

(23 Sep '13, 17:18) Bill Somers
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×270
×6

question asked: 23 Sep '13, 06:07

question was seen: 923 times

last updated: 23 Sep '13, 17:18