Hello!

I have a small database in ASA9, and like to load all database in memory, for more faster response. How i can do this?

Tanks

Douglas

asked 15 Aug '13, 13:50

DRauber's gravatar image

DRauber
21181119
accept rate: 0%


Hi Douglas, you can't load database in memory with ASA9. The only things you can do are:

  1. If you use 32 bit version, use -ch 1536M parameter so that the engine use a large cache. In 32 bit operative systems, the maximum cache available it's 1.6Gb
  2. If you use 64 bit version on a 64bit os the engine should use all the memory available as cache.

Be careful, I talk about cache. If you need in-memory option you should use newer versions ( it's available from 11.x ). Bye

permanent link

answered 16 Aug '13, 05:06

Giorgio%20Papagno's gravatar image

Giorgio Papagno
3062410
accept rate: 20%

1

you can't load database in memory with ASA9

I don't think so. Given enough cache (and we're talking about a small database!), you simply have to try to fill the cache with as many database pages as possible.

One way might to run some initial queries (select * from <whatever>) to load the according table's data.

Running DBVALID might do that internally.


However, usually SQL Anywhere will decide automatically what pages should be loaded for a fitting performance. So what exact problems do you face?

(16 Aug '13, 05:21) Volker Barth

Thanks for answer! sorry my bad english.. small ~3Gb, running on 64 bits CentOs, with 8Gb, only for the database server. The command line have the -ch75%% parameter, however some cases heavier, take several minutes to run.

(16 Aug '13, 08:15) DRauber

While putting more of your database data in RAM is always the first thing to try, it does not guarantee faster response time. For example, you may have runaway queries that consume vast amounts of CPU time, and/or use vast amounts of temporary space which may go to disk even though you have lots of RAM cache. You can query various PROPERTY(), DB_PROPERTY() and CONNECTION_PROPERTY() statistics to determine what's going on.

Or, you can save a lot of time and effort and run Foxhound which works on V9 databases.

permanent link

answered 20 Aug '13, 07:20

Breck%20Carter's gravatar image

Breck Carter
26.9k437609883
accept rate: 21%

edited 20 Aug '13, 07:21

Comment Text Removed

Do not run in FoxHound ASA9. What procedure should I do to run the ASA9?

(21 Aug '13, 15:33) Walmir Taques
Replies hidden

Foxhound Version 2 certainly does work with target databases that use SQL Anywhere 5.5, 6, 7, 8, 9, 10, 11 and 12.

Foxhound Version 2 itself requires SQL Anywhere 12.0.1.3298 or later.

See Foxhound 2 System Requirements

(21 Aug '13, 16:35) Breck Carter

I do not have the license Foxhound, and neither am DBA of the database in question, just wanted to do some tests to help a customer. Tanks

(22 Aug '13, 20:53) DRauber

Is there any manual for guidance on how to use / configure Foxhound? Is presenting this message when I try to access via firefox foxhound. (What should I do?)

C:\ProgramData\RisingRoad\Foxhound2>ECHO OFF
Start Foxhound via Firefox
Starting the Foxhound engine...
SQL Anywhere Start Server In Background Utility Version 12.0.1.3851
DBSPAWN ERROR:  -85
Communication error
******************************************************************
*** ERROR ********************************************************
*** dbspawn/dbsrv12 set ERRORLEVEL = 1
08/28 14:38:24. Can't start HTTP listener on address (::):80
Press any key to continue. . .
(28 Aug '13, 14:40) Walmir Taques
Replies hidden

I'd suggest to ask that as a separate question - or use the Foxhound homepage to see there...

(28 Aug '13, 15:08) Volker Barth
1

Google makes a good manual :)...

foxhound Can't start HTTP listener on address

http://www.risingroad.com/foxhound-2-0/faq/FAQ-Cant-start-HTTP-listener-on-address-127-0-0-1-80.html

Explanation: Some other process (Apache, IIS, Skype, another SQL Anywhere engine, etc) is already using TCP/IP port 80.

Either tell that process to stop using port 80 or tell Foxhound to use a different port.

For example, to stop Skype from using port 80:

Open the Skype window, click on Tools - Connection options... uncheck the "Use port 80 and 443 as an alternatives for incoming connections" option,

click on Save button and

restart Skype to make the change effective.

(28 Aug '13, 15:13) Breck Carter

OK, I do withdraw my suggestion - Breck is too fast:)

(28 Aug '13, 15:20) Volker Barth

:) sorry, I searched in Google * makes a good manual *

I ended up editing the file .Bat as suggested in:

Foxhound FAQ

no trial version foxhound?

(28 Aug '13, 16:01) Walmir Taques
Replies hidden
showing 4 of 9 show all flat view
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×3

question asked: 15 Aug '13, 13:50

question was seen: 764 times

last updated: 28 Aug '13, 17:40